[PATCH 1/2] gnu: Add r-bumpymatrix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
c6cead75b569c3dd196e91ff76d557f8969f9a41.1692883708.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-bumpymatrix): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 74071900a3..6204173277 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12913,6 +12913,33 @@ (define-public r-siggenes
Bayes Analyses of Microarrays} (EBAM).")
(license license:lgpl2.0+)))
+(define-public r-bumpymatrix
+ (package
+ (name "r-bumpymatrix")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BumpyMatrix" version))
+ (sha256
+ (base32
+ "021xn5d08phmwv6g8a5d4ap5kcf5syhm6vpr784l4k54lflssr5i"))))
+ (properties `((upstream-name . "BumpyMatrix")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-iranges r-matrix r-s4vectors))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/BumpyMatrix")
+ (synopsis "Bumpy matrix of non-scalar objects")
+ (description
+ "
+@code{BumpyMatrix} class and subclasses for storing non-scalar objects in matrix entries.
+This is akin to a ragged array but the raggedness is in the third dimension,
+much like a bumpy surface - hence the name. Of particular interest is the
+@code{BumpyDataFrameMatrix,} where each entry is a Bioconductor data frame.
+This allows us to naturally represent multivariate data in a format that is
+compatible with two-dimensional containers like the @code{SummarizedExperiment}
+and @code{MultiAssayExperiment} objects.")
+ (license license:expat)))
+
(define-public r-bumphunter
(package
(name "r-bumphunter")

base-commit: 39fa1ef033fda82cb1d122e0d1675b51acb1db34
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 65499-done@debbugs.gnu.org)
87cyz7fuhq.fsf@elephly.net
Applied with minor changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65499@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65499
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help