[PATCH] gnu: Add r-msigdb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
0e1abe23554c0125ec623d0926c7eb7d274c38f0.1692873517.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-msigdb): New variable.
---
gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 74071900a3..5e323d11ef 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1754,6 +1754,39 @@ (define-public r-msdata
files for various search engines.")
(license license:gpl2+)))
+(define-public r-msigdb
+ (package
+ (name "r-msigdb")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "msigdb" version
+ 'experiment))
+ (sha256
+ (base32
+ "1kgsqg1d5r852qas09g6fs0pcmk6jgbb6g983v6iqw19qsiy6jby"))))
+ (properties `((upstream-name . "msigdb")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotationdbi
+ r-annotationhub
+ r-experimenthub
+ r-gseabase
+ r-org-hs-eg-db
+ r-org-mm-eg-db))
+ (native-inputs (list r-knitr))
+ (home-page "https://davislaboratory.github.io/msigdb")
+ (synopsis "ExperimentHub package for the molecular signatures database")
+ (description
+ "R-msigdb provides the Molecular Signatures Database in a R accessible objects.
+Signatures are stored in @code{GeneSet} class objects form
+the GSEABase package and the entire database is stored in a
+@code{GeneSetCollection} object. These data are then hosted
+on the @code{ExperimentHub.} Data used in this package was
+obtained from the @code{MSigDB} of the Broad Institute.
+Metadata for each gene set is stored along with the gene
+set in the @code{GeneSet} class object.")
+ (license license:cc-by4.0)))
+
(define-public r-pasilla
(package
(name "r-pasilla")

base-commit: 160f78a4d92205df986ed9efcce7d3aac188cb24
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 65493-done@debbugs.gnu.org)
87h6ojfv3l.fsf@elephly.net
Applied with minor changes:

- changed the home page because it is not reachable (guix lint
complained)
- reflowed the description

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65493@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65493
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help