[PATCH] home: services: redshift: Use redshift package specified in configuration

  • Done
  • quality assurance status badge
Details
2 participants
  • Kjartan Oli Agustsson
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kjartan Oli Agustsson
Severity
normal

Debbugs page

Kjartan Oli Agustsson wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kjartan Oli Agustsson)(address . kjartanoli@outlook.com)
GV1P193MB2310FCC4B528A94EAC002C27DF1CA@GV1P193MB2310.EURP193.PROD.OUTLOOK.COM
* gnu/home/services/desktop.scm (redshift-shepherd-service): Use the redshift
package specified by config.
---
gnu/home/services/desktop.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index 626918fd9e..c4da116100 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -172,7 +172,7 @@ (define (redshift-shepherd-service config)
;; FIXME: This fails to start if Home is first activated from a
;; non-X11 session.
(start #~(make-forkexec-constructor
- (list #$(file-append redshift "/bin/redshift")
+ (list #$(file-append (home-redshift-configuration-redshift config) "/bin/redshift")
"-c" #$config-file)))
(stop #~(make-kill-destructor))
(actions (list (shepherd-configuration-action config-file))))))

base-commit: e318b62df361624e3bac70f658bcf5600ba5ca79
--
2.41.0
Ludovic Courtès wrote 1 years ago
(name . Kjartan Oli Agustsson)(address . kjartanoli@outlook.com)
87edj0c13v.fsf@gnu.org
Hi,

Kjartan Oli Agustsson <kjartanoli@outlook.com> skribis:

Toggle quote (3 lines)
> * gnu/home/services/desktop.scm (redshift-shepherd-service): Use the redshift
> package specified by config.

Good catch! Applied, thanks.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65480@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65480
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help