[PATCH] gnu: Add font-unscii.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 23 Aug 2023 14:06
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
7819b897b562d264eefb7d6cf5dc9a14317ec854.1692792387.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/fonts.scm (font-unscii): New variable.
---
gnu/packages/fonts.scm | 57 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 56 insertions(+), 1 deletion(-)

Toggle diff (86 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e881ab11cd..8266e40259 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Joshua Grant <tadni@riseup.net>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015, 2023 Sou Bunnbu <iyzsong@envs.net>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
@@ -98,6 +98,7 @@ (define-module (gnu packages fonts)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages xorg))
(define-public font-artifika
@@ -1175,6 +1176,60 @@ (define-public font-un
@end enumerate\n")
(license license:gpl2+)))
+(define-public font-unscii
+ (package
+ (name "font-unscii")
+ (version "2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://viznut.fi/unscii/unscii-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0msvqrq7x36p76a2n5bzkadh95z954ayqa08wxd017g4jpa1a4jd"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "otf" "ttf" "woff"))
+ (native-inputs (list bdftopcf fontforge perl perl-text-charwidth))
+ (inputs (list sdl sdl-image))
+ (arguments
+ (list #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((pcfdir (string-append
+ (assoc-ref outputs "out")
+ "/share/fonts/misc"))
+ (otfdir (string-append
+ (assoc-ref outputs "otf")
+ "/share/fonts/opentype"))
+ (ttfdir (string-append
+ (assoc-ref outputs "ttf")
+ "/share/fonts/truetype"))
+ (woffdir (string-append
+ (assoc-ref outputs "woff")
+ "/share/fonts/webfonts"))
+ (install-fonts
+ (lambda (pred dir)
+ (for-each
+ (lambda (f) (install-file f dir))
+ (find-files "." pred)))))
+ (install-fonts "\\.pcf$" pcfdir)
+ (install-fonts "\\.otf$" otfdir)
+ (install-fonts "\\.ttf$" ttfdir)
+ (install-fonts "\\.woff$" woffdir)))))))
+ (synopsis "Classic bitmapped Unicode fonts")
+ (description
+ "Unscii is a set of bitmapped Unicode fonts based on classic system
+fonts. Unscii attempts to support character cell art well while also being
+suitable for terminal and programming use. The two main variants are
+unscii-8 (8×8 pixels per glyph) and unscii-16 (8×16).")
+ (home-page "http://viznut.fi/unscii/")
+ ;; "unscii-16-full" falls under GPL, the other are in the Public Domain.
+ (license (list license:gpl2+ license:public-domain))))
+
(define-public font-fantasque-sans
(package
(name "font-fantasque-sans")

base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
--
2.41.0
?
(address . 65473-done@debbugs.gnu.org)
87fs43phfe.fsf@envs.net
Pushed now, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65473@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65473
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch