(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
* gnu/packages/pantheon.scm (granite):?Upgrade to 7.3.0.
---
This is a work in progress, as I have noted two problems.
First is: guix lint says
"label 'glib' does not match package name 'glib:bin"
but looking at the package reference in the manual,
I don’t get why the way I wrote it is wrong.
Second: guix size reports a doubled size, but I don’t
know if anything can be done about it.
gnu/packages/pantheon.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)
Toggle diff (50 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 1c6795cc1d..c5cbde24c0 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages pantheon)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages web)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
@@ -40,7 +41,7 @@ (define-module (gnu packages pantheon)
(define-public granite
(package
(name "granite")
- (version "6.2.0")
+ (version "7.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -49,16 +50,20 @@ (define-public granite
(file-name (git-file-name name version))
(sha256
(base32
- "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+ "0pyvkif2kin5dskh7adadsh4r96mvx12y7cs6gnm0ml733q548dj"))))
(build-system meson-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'disable-icon-cache
(lambda _
(setenv "DESTDIR" "/"))))))
- (inputs (list glib gtk+ libgee))
- (native-inputs (list gettext-minimal gobject-introspection pkg-config
- python vala))
+ (inputs (list glib gtk libgee sassc))
+ (native-inputs (list gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ pkg-config
+ python
+ vala))
(home-page "https://github.com/elementary/granite")
(synopsis "Library that extends GTK with common widgets and utilities")
(description "Granite is a companion library for GTK+ and GLib. Among other
base-commit: 0c4fb8f43f8aba2dcabe1bc97a8f6d8d41057704
--
2.41.0