Hello,
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
Toggle quote (7 lines)
> Hi,
>
> I failed to notice this in time for the merge, but it appears qtbase now
> keeps a reference to Python 3.10, which increases its size a bit.
>
> It should be removed.
Toggle snippet (22 lines)
modified gnu/packages/qt.scm
@@ -634,6 +634,8 @@ (define-public qtbase
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments qtbase-5)
+ ((#:disallowed-references _ #f)
+ (list python))
((#:configure-flags _ ''())
`(let ((out (assoc-ref %outputs "out")))
(list "-DQT_BUILD_TESTS=ON"
@@ -727,7 +729,8 @@ (define-public qtbase
(add-after 'patch-source-shebangs 'do-not-capture-python
(lambda _
(substitute* '("mkspecs/features/uikit/devices.py"
- "util/testrunner/qt-testrunner.py")
+ "util/testrunner/qt-testrunner.py"
+ "util/testrunner/sanitizer-testrunner.py")
(((which "python3"))
"/usr/bin/env python3"))))
(replace 'configure
I'll push the fix to the telephony-team branch, since I had just removed
the qt-updates one.
--
Thanks,
Maxim