qtbase refers to python 3

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 22 Aug 2023 20:18
(name . bug-guix)(address . bug-guix@gnu.org)
87bkezaqlh.fsf@gmail.com
Hi,

I failed to notice this in time for the merge, but it appears qtbase now
keeps a reference to Python 3.10, which increases its size a bit.

It should be removed.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 22 Aug 2023 21:13
(address . 65457-done@debbugs.gnu.org)
877cpmc2ma.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (7 lines)
> Hi,
>
> I failed to notice this in time for the merge, but it appears qtbase now
> keeps a reference to Python 3.10, which increases its size a bit.
>
> It should be removed.

Fixes, like so:

Toggle snippet (22 lines)
modified gnu/packages/qt.scm
@@ -634,6 +634,8 @@ (define-public qtbase
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments qtbase-5)
+ ((#:disallowed-references _ #f)
+ (list python))
((#:configure-flags _ ''())
`(let ((out (assoc-ref %outputs "out")))
(list "-DQT_BUILD_TESTS=ON"
@@ -727,7 +729,8 @@ (define-public qtbase
(add-after 'patch-source-shebangs 'do-not-capture-python
(lambda _
(substitute* '("mkspecs/features/uikit/devices.py"
- "util/testrunner/qt-testrunner.py")
+ "util/testrunner/qt-testrunner.py"
+ "util/testrunner/sanitizer-testrunner.py")
(((which "python3"))
"/usr/bin/env python3"))))
(replace 'configure

I'll push the fix to the telephony-team branch, since I had just removed
the qt-updates one.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65457@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65457
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch