[PATCH] gnu-maintenance: Improve check for disabled host names.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 21 Aug 2023 22:56
a20a2de8e964dbc07cde94f7cadc2c923c6ec3b6.1692651381.git.maxim.cournoyer@gmail.com
Found while investigating https://issues.guix.gnu.org/65304.

* guix/gnu-maintenance.scm (html-updatable-package?): Tighten predicate.
---

guix/gnu-maintenance.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index 32712f7218..5c16a7617d 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -846,7 +846,11 @@ (define html-updatable-package?
(let ((scheme (uri-scheme uri))
(host (uri-host uri)))
(and (memq scheme '(http https))
- (not (member host hosting-sites)))))))))
+ ;; HOST may contain prefixes,
+ ;; e.g. "profanity-im.github.io", hence the
+ ;; suffix-based test below.
+ (not (any (cut string-suffix? <> host)
+ hosting-sites)))))))))
(lambda (package)
(or (assoc-ref (package-properties package) 'release-monitoring-url)

base-commit: 4c7627dfec88350f9a1705e9527c38dd41506f8b
--
2.41.0
L
L
Ludovic Courtès wrote on 22 Aug 2023 18:28
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87bkez3utt.fsf@gnu.org
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (4 lines)
> Found while investigating https://issues.guix.gnu.org/65304.
>
> * guix/gnu-maintenance.scm (html-updatable-package?): Tighten predicate.

LGTM!
M
M
Maxim Cournoyer wrote on 25 Aug 2023 16:08
Re: bug#65444: [PATCH] gnu-maintenance: Improve check for disabled host names.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87h6on9pui.fsf_-_@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> Found while investigating <https://issues.guix.gnu.org/65304>.
>>
>> * guix/gnu-maintenance.scm (html-updatable-package?): Tighten predicate.
>
> LGTM!

This change was installed with
c655231b72ac28b5a433069fcf86a835c9c83691. Thanks for the review!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65444@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65444
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch