(address . guix-patches@gnu.org)
Hi Guix,
Please find the patch attached. Thanks.
--
André A. Gomes
"You cannot even find the ruins..."
From 617be92d3276502abe410fb2c175a97937b853c1 Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Mon, 21 Aug 2023 23:14:44 +0300
Subject: [PATCH] gnu: Add emacs-vcard-mode.
* gnu/packages/emacs-xyz.scm (emacs-vcard-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..98328f29d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37904,6 +37904,28 @@ (define-public emacs-project-x
across sessions.")
(license license:gpl3+))))
+(define-public emacs-vcard-mode
+ ;; Use the latest commit, as there are no tagged releases.
+ (let ((commit "ab1a2885a5720d7fb02d9b6583ee908ba2260b78")
+ (revision "0"))
+ (package
+ (name "emacs-vcard-mode")
+ (home-page "https://github.com/dochang/vcard-mode")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w44ax9dxkj8mh4np9mg3yp2yakjwrgy13izq53p0vimrhywza0w"))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs major mode to edit vCard files")
+ (description "A major mode to edit vCard files in Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-vertico-posframe
(package
(name "emacs-vertico-posframe")
--
2.41.0