[PATCH 1/3] gnu: Add r-maptree.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
644667be3cab344a644978979696edd10c45ae03.1692625477.git.navid.afkhami@mdc-berlin.de
* gnu/packages/statistics.scm (r-maptree): New variable.
---
gnu/packages/statistics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5abc62d760..41243ca7a7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -433,6 +433,28 @@ (define r-with-tests
available, greatly increasing its breadth and scope.")
(license license:gpl3+)))
+(define-public r-maptree
+ (package
+ (name "r-maptree")
+ (version "1.4-8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "maptree" version))
+ (sha256
+ (base32
+ "1x35nk4fi2b62krcvcv187n5sbqrgvw4pbm7r19ps3jlanpi5ksm"))))
+ (properties `((upstream-name . "maptree")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cluster r-rpart))
+ (home-page "https://cran.r-project.org/package=maptree")
+ (synopsis "Mapping, pruning, and graphing tree models")
+ (description
+ "Set of functions with example data for graphing, pruning, and mapping models.
+These moldes are from hierarchical clustering, and classification and
+regression trees.")
+ ;; Custom license, see https://cran.r-project.org/web/packages/maptree/index.html
+ (license (license:non-copyleft "file://DESCRIPTION"))))
+
(define-public r-minimal
(package (inherit r-with-tests)
(name "r-minimal")

base-commit: 3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 65428-done@debbugs.gnu.org)
87ttsjfvn7.fsf@elephly.net
Applied with changes to the description (to use complete sentences) and
to the license comment.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65428@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65428
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help