[PATCH] gnu: Add qogir-icon-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • ???
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 21 Aug 2023 14:36
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
700dcc14e4a98bb114fff01013a04dc7ca568828.1692621227.git.hako@ultrarare.space
* gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.
---
gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a1701aaa77..6ba0ee0092 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -240,6 +240,39 @@ (define-public papirus-icon-theme
and a few extra features.")
(license license:gpl3)))
+(define-public qogir-icon-theme
+ (package
+ (name "qogir-icon-theme")
+ (version "2023.06.05")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vinceliuice/Qogir-icon-theme")
+ (commit (string-replace-substring version "." "-"))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "install.sh"
+ (("gtk-update-icon-cache") "true")))
+ (sha256
+ (base32
+ "1kn8b9zdamxbfbs7b9qpx53hmjw2l40sxpjw93axb1dqy81yc8da"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let* ((dest (string-append #$output "/share/icons"))
+ (flags (list "--theme" "all"
+ "--color" "all"
+ "--dest" dest)))
+ (mkdir-p dest)
+ (apply invoke "bash" "install.sh" flags)))))))
+ (home-page "https://www.pling.com/p/1296407/")
+ (synopsis "Flat colorful design icon theme")
+ (description "This package provides a flat colorful design icon theme.")
+ (license license:gpl3)))
+
(define-public flat-remix-icon-theme
(package
(name "flat-remix-icon-theme")

base-commit: 182e8ddfc1e88a6ece7e96e0b9535ad44c3c6da6
--
2.41.0
?
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 65425@debbugs.gnu.org)
871qfqlcob.fsf@envs.net
Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (2 lines)
> * gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.

Looks good to me, thanks!
H
H
Hilton Chain wrote on 29 Aug 2023 17:18
(name . ????)(address . iyzsong@envs.net)(address . 65425-done@debbugs.gnu.org)
87ledt27y9.wl-hako@ultrarare.space
On Sat, 26 Aug 2023 11:12:20 +0800,
??? wrote:
Toggle quote (7 lines)
>
> Hilton Chain <hako@ultrarare.space> writes:
>
> > * gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.
>
> Looks good to me, thanks!

Thank you for taking a look!
Pushed as 77843170f0b7f5189892bd650d127f42151fa591.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65425@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65425
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch