[PATCH] gnu: prboom-plus: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 20 Aug 2023 14:55
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
89e503311aee019d19b3c016cb8c579852cd8bb0.1692536100.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/games.scm (prboom-plus)[arguments]<#:phases>:
Set CFLAGS to '-fcommon'.
---
gnu/packages/games.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..4563089326 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2381,6 +2381,9 @@ (define-public prboom-plus
(assoc-ref %outputs "out") "/bin"))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-CFLAGS
+ (lambda _
+ (setenv "CFLAGS" "-fcommon")))
(add-after 'set-paths 'set-sdl'paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"

base-commit: 95a1a819dffa833bdd7a47f272da7ee4ff3260c8
--
2.41.0
L
L
Liliana Marie Prikler wrote on 20 Aug 2023 17:43
(name . ???)(address . iyzsong@member.fsf.org)
a7482d62d9a960d5cd1892d7303d6c9a41da1e74.camel@gmail.com
Am Sonntag, dem 20.08.2023 um 20:55 +0800 schrieb iyzsong@envs.net:
Toggle quote (20 lines)
> From: ??? <iyzsong@member.fsf.org>
>
> * gnu/packages/games.scm (prboom-plus)[arguments]<#:phases>:
> Set CFLAGS to '-fcommon'.
> ---
>  gnu/packages/games.scm | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a5fa19fc20..4563089326 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -2381,6 +2381,9 @@ (define-public prboom-plus
>                                       (assoc-ref %outputs "out")
> "/bin"))
>        #:phases
>        (modify-phases %standard-phases
> +        (add-before 'configure 'set-CFLAGS
> +          (lambda _
> +            (setenv "CFLAGS" "-fcommon")))
Could this be added via #:configure-flags?
I
I
iyzsong wrote on 21 Aug 2023 12:31
[PATCH v2] gnu: prboom-plus: Fix build.
(address . 65410@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
a77aeb1bf40a82055baa0e9762429be45ac45b4e.1692613840.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/games.scm (prboom-plus)[arguments]<#:configure-flags>:
Add "CFLAGS=-fcommon".
---
gnu/packages/games.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..e1b6dbd43b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2376,7 +2376,7 @@ (define-public prboom-plus
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-cpu-opt")
+ '(#:configure-flags '("--disable-cpu-opt" "CFLAGS=-fcommon")
#:make-flags `(,(string-append "gamesdir="
(assoc-ref %outputs "out") "/bin"))
#:phases

base-commit: 3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1
--
2.41.0
?
Re: bug#65410: [PATCH] gnu: prboom-plus: Fix build.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87lee4ptxs.fsf_-_@envs.net
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (5 lines)
> Am Sonntag, dem 20.08.2023 um 20:55 +0800 schrieb iyzsong@envs.net:
>> +          (lambda _
>> +            (setenv "CFLAGS" "-fcommon")))
> Could this be added via #:configure-flags?

Yes, updated patch sent, thanks!
?
(address . 65410-done@debbugs.gnu.org)
877cpmyqfk.fsf_-_@envs.net
Pushed now, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65410@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65410
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch