(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
From: ??? <iyzsong@member.fsf.org>
* gnu/packages/games.scm (prboom-plus)[arguments]<#:phases>:
Set CFLAGS to '-fcommon'.
---
gnu/packages/games.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..4563089326 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2381,6 +2381,9 @@ (define-public prboom-plus
(assoc-ref %outputs "out") "/bin"))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-CFLAGS
+ (lambda _
+ (setenv "CFLAGS" "-fcommon")))
(add-after 'set-paths 'set-sdl'paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
base-commit: 95a1a819dffa833bdd7a47f272da7ee4ff3260c8
--
2.41.0