(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
From: ??? <iyzsong@member.fsf.org>
* gnu/packages/games.scm (alex4)[arguments]: Add '-fcommon' to CFLAGS.
---
gnu/packages/games.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..512834cba8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -430,7 +430,7 @@ (define-public alex4
`(#:tests? #f ; no check target
#:make-flags
(list "CC=gcc"
- "CFLAGS=-D_FILE_OFFSET_BITS=64"
+ "CFLAGS=-D_FILE_OFFSET_BITS=64 -fcommon"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
base-commit: ad5e4fe54a66c725dc03dedebf8e5c65723ccb74
--
2.41.0