aegis fails to build

  • Open
  • quality assurance status badge
Details
One participant
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 20 Aug 2023 01:58
(name . bug-guix)(address . bug-guix@gnu.org)
cedac34b-b6db-422b-f88a-7c185b2b4be2@telenet.be
g++ -I. -std=c++03
-I/gnu/store/b727ryyfiz1cfdywjp8s1wmxd6lzsz8p-curl-7.85.0/include
-I/gnu/store/g9cpfynzy3ryv9jprgvwf3g2mnd5p11q-libxml2-2.9.14/include/libxml2
-c fmtgen/lex.cc
In file included from
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/include/c++/x86_64-unknown-linux-gnu/bits/os_defines.h:39,
from
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/include/c++/x86_64-unknown-linux-gnu/bits/c++config.h:586,
from
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/include/c++/cstdio:41,
from ./common/ac/stdio.h:26,
from fmtgen/lex.cc:20:
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/include/features.h:194:3:
warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use
_DEFAULT_SOURCE" [-Wcpp]
194 | # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use
_DEFAULT_SOURCE"
| ^~~~~~~
In file included from fmtgen/lex.cc:33:
./fmtgen/parse.gen.h:77: warning: "parse_error" redefined
77 | #define parse_error 256
|
In file included from fmtgen/lex.cc:31:
./fmtgen/lex.h:38: note: this is the location of the previous definition
38 | #define parse_error parse_error
|
In file included from fmtgen/lex.cc:33:
./fmtgen/parse.gen.h:55:19: error: ?parse_error? redeclared as different
kind of entity
55 | parse_error = 256, /* error */
| ^~~
In file included from fmtgen/lex.cc:31:
./fmtgen/lex.h:28:6: note: previous declaration ?void parse_error(const
char*, ...)?
28 | void parse_error(const char *, ...)
ATTR_PRINTF(1, 2);
| ^~~~~~~~~~~
fmtgen/lex.cc: In function ?int parse_lex()?:
fmtgen/lex.cc:328:36: error: expression cannot be used as a function
328 | parse_error("end-of-file inside comment");
fmtgen/lex.cc:375:32: error: expression cannot be used as a function
375 | parse_error("end-of-file within string");
fmtgen/lex.cc:382:32: error: expression cannot be used as a function
382 | parse_error("end-of-line within string");
fmtgen/lex.cc:393:36: error: expression cannot be used as a function
393 | parse_error("unknown '\\%c' escape", c);
In file included from fmtgen/lex.cc:33:
fmtgen/lex.cc: At global scope:
./fmtgen/parse.gen.h:77:21: error: expected unqualified-id before
numeric constant
77 | #define parse_error 256
| ^~~
fmtgen/lex.cc:482:1: note: in expansion of macro ?parse_error?
482 | parse_error(const char *s, ...)
| ^~~~~~~~~~~
make: *** [Makefile:10059: fmtgen/lex.o] Error 1
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: () exit-status: 2
term-signal: #f stop-signal: #f>
phase `build' failed after 0.4 seconds
command "make" failed with status 2
builder for `/gnu/store/xjljfdy41dmf9swsfqd81vhgv4pkqaj8-aegis-4.24.drv'
failed with exit code 1
@ build-failed
/gnu/store/xjljfdy41dmf9swsfqd81vhgv4pkqaj8-aegis-4.24.drv - 1 builder
for `/gnu/store/xjljfdy41dmf9swsfqd81vhgv4pkqaj8-aegis-4.24.drv' failed
with exit code 1
---
one-by-one, albeit not in the same order as listed there.)
Attachment: OpenPGP_signature
?