[PATCH] gnu: Add qgit.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 18 Aug 2023 16:52
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
20230818145246.8135-1-sughosha@disroot.org
* gnu/packages/version-control.scm (qgit): New variable.
---
gnu/packages/version-control.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 699a091..5143438 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -79,6 +79,7 @@ (define-module (gnu packages version-control)
#:use-module (guix build-system go)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
@@ -1297,7 +1298,7 @@ (define-public python-gitpython
either a pure Python implementation, or the faster, but more resource intensive
@command{git} command implementation.")
(license license:bsd-3)))
-
+
(define-public savane
(package
(name "savane")
@@ -3545,6 +3546,40 @@ (define-public tkrev
TkDiff is included for browsing and merging your changes.")
(license license:gpl2+)))
+(define-public qgit
+ (package
+ (name "qgit")
+ (version "2.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tibirna/qgit")
+ (commit (string-append "qgit-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10j5xll7ai1rb2ybyblbgqm762bqspffpf33fdr61qdchnp2gkf4"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (propagated-inputs
+ (list git))
+ (home-page "https://github.com/tibirna/qgit")
+ (synopsis "Graphical front-end for git")
+ (description
+ "Qgit is a graphical front-end for git, with features to:
+@itemize
+@item view revisions, diffs, files history, files annotation and archive tree,
+@item commit changes visually cherry picking modified files,
+@item apply or save patch series from selected commits, drag and drop commits,
+@item associate commands sequences, scripts and anything else executable to a
+ custom action,
+@item push/pop commits,
+@item apply/save/create patches
+@item and cherry pick single modified files.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public git-filter-repo
(package
(name "git-filter-repo")
--
libgit2 1.5.1
M
M
Maxim Cournoyer wrote on 5 Sep 2023 15:27
(name . Sughosha)(address . sughosha@disroot.org)(address . 65365@debbugs.gnu.org)
87bkeglph4.fsf@gmail.com
Hi Sughosha,

Sughosha <sughosha@disroot.org> writes:

Toggle quote (64 lines)
> * gnu/packages/version-control.scm (qgit): New variable.
> ---
> gnu/packages/version-control.scm | 37 ++++++++++++++++++++++++++++++++++++-
> 1 file changed, 36 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 699a091..5143438 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -79,6 +79,7 @@ (define-module (gnu packages version-control)
> #:use-module (guix build-system go)
> #:use-module (guix build-system perl)
> #:use-module (guix build-system python)
> + #:use-module (guix build-system qt)
> #:use-module (guix build-system trivial)
> #:use-module (gnu packages apr)
> #:use-module (gnu packages autotools)
> @@ -1297,7 +1298,7 @@ (define-public python-gitpython
> either a pure Python implementation, or the faster, but more resource intensive
> @command{git} command implementation.")
> (license license:bsd-3)))
> -
> +
> (define-public savane
> (package
> (name "savane")
> @@ -3545,6 +3546,40 @@ (define-public tkrev
> TkDiff is included for browsing and merging your changes.")
> (license license:gpl2+)))
>
> +(define-public qgit
> + (package
> + (name "qgit")
> + (version "2.10")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/tibirna/qgit")
> + (commit (string-append "qgit-" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "10j5xll7ai1rb2ybyblbgqm762bqspffpf33fdr61qdchnp2gkf4"))))
> + (build-system qt-build-system)
> + (arguments
> + (list #:tests? #f)) ;no tests
> + (propagated-inputs
> + (list git))
> + (home-page "https://github.com/tibirna/qgit")
> + (synopsis "Graphical front-end for git")
> + (description
> + "Qgit is a graphical front-end for git, with features to:
> +@itemize
> +@item view revisions, diffs, files history, files annotation and archive tree,
> +@item commit changes visually cherry picking modified files,
> +@item apply or save patch series from selected commits, drag and drop commits,
> +@item associate commands sequences, scripts and anything else executable to a
> + custom action,
> +@item push/pop commits,
> +@item apply/save/create patches
> +@item and cherry pick single modified files.
> +@end itemize")
> + (license license:gpl3+)))

Does this build using Qt 6? If so, it'd be best to provide the #:qtbase
argument with the package qtbase, which is at version 6 (by default it
currently still uses Qt 5).

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 5 Sep 2023 15:27
control message for bug #65365
(address . control@debbugs.gnu.org)
87a5u0lpgy.fsf@gmail.com
tags 65365 + moreinfo
quit
S
S
sughosha wrote on 17 Sep 2023 10:07
Re: bug#65365: [PATCH] gnu: Add qgit.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65365@debbugs.gnu.org)
0c66dcc7fa33ae5c659e1b0ec1ae951a@disroot.org
Hi Maxim,

Am 2023-09-05 15:27, schrieb Maxim Cournoyer:

Toggle quote (5 lines)
> Does this build using Qt 6? If so, it'd be best to provide the
> #:qtbase
> argument with the package qtbase, which is at version 6 (by default it
> currently still uses Qt 5).

No. The build fails without Qt5Config.cmake.

Regards,

Sughosha
Attachment: file
M
M
Maxim Cournoyer wrote on 17 Sep 2023 22:28
(name . sughosha)(address . sughosha@disroot.org)(address . 65365-done@debbugs.gnu.org)
87pm2g7ddj.fsf@gmail.com
Hi,

sughosha <sughosha@disroot.org> writes:

Toggle quote (11 lines)
> Hi Maxim,
>
> Am 2023-09-05 15:27, schrieb Maxim Cournoyer:
>
>> Does this build using Qt 6? If so, it'd be best to provide the
>> #:qtbase
>> argument with the package qtbase, which is at version 6 (by default it
>> currently still uses Qt 5).
>
> No. The build fails without Qt5Config.cmake.

Thanks for the response. Installed!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65365@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65365
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch