[PATCH] gnu: Add python-scDamAndTools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 18 Aug 2023 16:01
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
fa8a55823ad0ad4f36c81fb7d6957a80f85d434a.1692367266.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-scDamAndTools): New variable.
---
gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 51640b710f..03b1e81634 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2154,6 +2154,40 @@ (define-public python-pybedtools
;; licensed lgpl2.1+
(license (list license:expat license:lgpl2.1+))))
+(define-public python-scDamAndTools
+ (package
+ (name "python-scDamAndTools")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KindLab/scDamAndTools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mblw6cn5jqik6ky8cv7ry99z6jm1i4r71pzdfl398vrwbda65gd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ;there are none
+ (propagated-inputs (list python-h5py
+ python-numpy
+ python-sortedcontainers
+ python-pandas
+ python-pysam
+ python-tqdm))
+ (native-inputs (list python-cython python-pytest))
+ (home-page "https://github.com/KindLab/scDamAndTools")
+ (synopsis "Functions for processing raw scDam&T-seq data")
+ (description
+ "This is a set of unctions for processing raw scDam&T-seq data.
+A method to simultaneously measure protein-DNA interactions and transcription
+from single cells (Rooijers et al., 2019). scDam&T-seq combines a DamID-based
+method to measure protein-DNA interactions and an adaptation of CEL-Seq to
+measure transcription. The starting point of the workflow is raw sequencing
+data and the end result are tables of UMI-unique DamID and CEL-Seq counts.")
+ (license license:expat)))
+
(define-public python-bioframe
(package
(name "python-bioframe")

base-commit: 1b2d43fe016848ea2ec16ff18cbc14340944fc4e
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Aug 2023 09:51
(address . 65364-done@debbugs.gnu.org)
87y1hvfvt1.fsf@elephly.net
Thanks for the patch. I renamed it to all lowercase and changed the
description a little bit.

Pushed!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65364@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65364
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch