[PATCH] gnu: linux-libre: Fix aarch64 build by providing hexdump command

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Pierre Langlois
Owner
unassigned
Submitted by
Pierre Langlois
Severity
normal
P
P
Pierre Langlois wrote on 15 Aug 2023 23:23
(address . guix-patches@gnu.org)
87y1icgfa6.fsf@gmx.com
Hi Guix!

I noticed linux 6.4 didn't build on aarch64
checking the log, it seems we're simply missing the `hexdump' column:

Toggle snippet (21 lines)
CC [M] drivers/pci/controller/pcie-rockchip-host.mod.o
OBJCOPY arch/arm64/boot/Image
CC [M] drivers/pci/controller/pcie-brcmstb.mod.o
AS arch/arm64/boot/zboot-header.o
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
make[1]: hexdump: No such file or directory
PAD arch/arm64/boot/vmlinux.bin
CC [M] drivers/pci/controller/pcie-apple.mod.o
truncate: Invalid number: 'arch/arm64/boot/vmlinux.bin'
make[1]: *** [drivers/firmware/efi/libstub/Makefile.zboot:13: arch/arm64/boot/vmlinux.bin] Error 1
make[1]: *** Deleting file 'arch/arm64/boot/vmlinux.bin'
make: *** [arch/arm64/Makefile:163: vmlinuz.efi] Error 2
make: *** Waiting for unfinished jobs....
CC [M] drivers/pci/pci-stub.mod.o
CC [M] drivers/video/backlight/ams369fg06.mod.o
CC [M] drivers/video/backlight/lcd.mod.o
CC [M] drivers/video/backlight/hx8357.mod.o

The "PAD" line seems to come from this Makefile, imported in a few

So the fix is easy! Somebody probably already found the issue, but I
figure I'd post the fix in case it saves time :-)

Thanks!
Pierre
-----BEGIN PGP SIGNATURE-----

iQFMBAEBCgA2FiEEctU9gYy29KFyWDdMqPyeRH9PfVQFAmTb76EYHHBpZXJyZS5s
YW5nbG9pc0BnbXguY29tAAoJEKj8nkR/T31Uc54IAJGg9Oce1mJs3jbhVNo5/Odr
vq/wIPOrUJXZcOQjThxYUm4OdG7RvQ0bM0v5DLKJyBUKxvZZXSy3xMloESIwwsZY
l22oJdo8PhbQCAmO7XRFj7bR+VPLPvG1sl7D9CoGqBJ44a2fesJ4W3p2RNfIZdgL
DUz/p979zvQe+mCvtC1zFfzhZ+603Y0hm8vBRko0cwiT9KslptfxZK5loFtTxtUH
4H0ZljgcCKmFwhjAgITCQf08x1laCge/qWj3GQ148FNziIPInsOWvwRo97lDvBJ8
j8u3uG9zsqMcYpStPxvAEJq7/e9UqpwKTWn76MaL7TzETVPwmX9Ws0eQHS7f7ZA=
=daRO
-----END PGP SIGNATURE-----

From d20fa084807706fd3fccaa2104162843420c282c Mon Sep 17 00:00:00 2001
Message-ID: <d20fa084807706fd3fccaa2104162843420c282c.1692134779.git.pierre.langlois@gmx.com>
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Tue, 15 Aug 2023 22:10:02 +0100
Subject: [PATCH] gnu: linux-libre: Add util-linux native input.

Provide `hexdump' needed to build compressed EFI payload, on aarch64.

* gnu/packages/linux.scm (make-linux-libre*)[native-inputs]: Add util-linux.
---
gnu/packages/linux.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 686eb40587..48dda8cda9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1071,7 +1071,9 @@ (define* (make-linux-libre* version gnu-revision source supported-systems
;; These are needed to compile the GCC plugins.
gmp
mpfr
- mpc))
+ mpc
+ ;; Provide hexdump command, needed on aarch64.
+ util-linux))
(home-page "https://www.gnu.org/software/linux-libre/")
(synopsis "100% free redistribution of a cleaned Linux kernel")
(description "GNU Linux-Libre is a free (as in freedom) variant of the

base-commit: 6eb0070f088cfdc4edb98fcfbea4b7aa68a2e30a
--
2.41.0
M
M
Mathieu Othacehe wrote on 5 Oct 2023 17:18
(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
87lechumg8.fsf@gnu.org
Hello Pierre,

Toggle quote (4 lines)
> I noticed linux 6.4 didn't build on aarch64
> https://ci.guix.gnu.org/build/1787394/details, building it locally and
> checking the log, it seems we're simply missing the `hexdump' column:

I made a similar patch couple weeks ago without noticing yours, sorry
about that! Closing.

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65322@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65322
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch