[PATCH] gnu: knights: Fix build.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 15 Aug 2023 13:39
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
9300c9741c7d46100b6e8b4923695fc3f0806c3c.1692099588.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/games.scm (knights)[source]: Add snippet.
---
gnu/packages/games.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5fa19fc20..3d4e87a2db 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1890,7 +1890,13 @@ (define-public knights
version "_src.tar.gz"))
(sha256
(base32
- "18vp2ygvn0s0jz8rm585jqf6hjqkam1ximq81k0r9hpmfj7wb88f"))))
+ "18vp2ygvn0s0jz8rm585jqf6hjqkam1ximq81k0r9hpmfj7wb88f"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix a missing include for std::map.
+ #~(substitute* "src/shared/impl/lua_func_wrapper.cpp"
+ (("#include \"misc[.]hpp\"" x)
+ (string-append "#include <map>\n" x))))))
(build-system gnu-build-system)
(arguments
'(#:make-flags

base-commit: f2943958a224beda05a3d040876df2a7285cd7a2
--
2.41.0
?
(address . 65309-done@debbugs.gnu.org)
874jkqyqes.fsf@envs.net
Pushed now, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch