[PATCH emacs-team] gnu: notmuch: Fix tests with Emacs 29

  • Done
  • quality assurance status badge
Details
2 participants
  • Arjan Adriaanse
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Arjan Adriaanse
Severity
normal
A
A
Arjan Adriaanse wrote on 15 Aug 2023 00:38
(address . guix-patches@gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
2d028a2e7676f2d9a7f6dbc276cc663245bf212a.1692052705.git.arjan@adriaan.se
* gnu/packages/mail.scm (notmuch): Add patch.
* gnu/packages/patches/notmuch-emacs-test-output.patch: Add file.
---
gnu/packages/mail.scm | 6 +-
.../patches/notmuch-emacs-test-output.patch | 89 +++++++++++++++++++
2 files changed, 94 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/notmuch-emacs-test-output.patch

Toggle diff (123 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a6f571e723..fb1ba35d21 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1383,7 +1384,10 @@ (define-public notmuch
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
version ".tar.xz"))
(sha256
- (base32 "1xl64xh0ijfkx265lcj9cqv1wkzha8gsn9jn4fw4xgvqigr6sxhf"))))
+ (base32 "1xl64xh0ijfkx265lcj9cqv1wkzha8gsn9jn4fw4xgvqigr6sxhf"))
+ (patches
+ ;; Output for some tests varies slightly in Emacs 29.
+ (search-patches "notmuch-emacs-test-output.patch"))))
(build-system gnu-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/notmuch-emacs-test-output.patch b/gnu/packages/patches/notmuch-emacs-test-output.patch
new file mode 100644
index 0000000000..3c6d472d6b
--- /dev/null
+++ b/gnu/packages/patches/notmuch-emacs-test-output.patch
@@ -0,0 +1,89 @@
+From e9e779ead4d703ad423e46c23abd0c9afd7d5ed2 Mon Sep 17 00:00:00 2001
+From: Arjan Adriaanse <arjan@adriaan.se>
+Date: Tue, 15 Aug 2023 00:00:05 +0200
+Subject: [PATCH] test: fix expected output for Emacs 29
+
+---
+ test/T453-emacs-reply.sh | 1 -
+ test/T454-emacs-dont-reply-names.sh | 9 +++------
+ .../notmuch-reply-duplicate-4 | 1 -
+ 3 files changed, 3 insertions(+), 8 deletions(-)
+
+diff --git a/test/T453-emacs-reply.sh b/test/T453-emacs-reply.sh
+index 0a27d066..de400b85 100755
+--- a/test/T453-emacs-reply.sh
++++ b/test/T453-emacs-reply.sh
+@@ -17,7 +17,6 @@ cat <<EOF > EXPECTED
+ From: Notmuch Test Suite <test_suite@notmuchmail.org>
+ To: Antoine Beaupré <anarcat@orangeseeds.org>
+ Subject: Re: bug: "no top level messages" crash on Zen email loops
+-In-Reply-To: <874llc2bkp.fsf@curie.anarc.at>
+ Fcc: MAIL_DIR/sent
+ --text follows this line--
+ Antoine Beaupré <anarcat@orangeseeds.org> writes:
+diff --git a/test/T454-emacs-dont-reply-names.sh b/test/T454-emacs-dont-reply-names.sh
+index 3a770177..9ed4f18b 100755
+--- a/test/T454-emacs-dont-reply-names.sh
++++ b/test/T454-emacs-dont-reply-names.sh
+@@ -17,13 +17,12 @@ test_emacs '(let ((message-dont-reply-to-names "notmuchmail\\|noreply\\|harvard"
+ (test-visible-output "OUTPUT-FULL.raw"))'
+
+ notmuch_dir_sanitize < OUTPUT-FULL.raw > OUTPUT-FULL
+-head -6 OUTPUT-FULL > OUTPUT
++head -5 OUTPUT-FULL > OUTPUT
+
+ cat <<EOF > EXPECTED
+ From: Notmuch Test Suite <test_suite@notmuchmail.org>
+ To: Mikhail Gusarov <dottedmag@dottedmag.net>
+ Subject: Re: [notmuch] Working with Maildir storage?
+-In-Reply-To: <20091117203301.GV3165@dottiness.seas.harvard.edu>
+ Fcc: MAIL_DIR/sent
+ --text follows this line--
+ EOF
+@@ -38,14 +37,13 @@ test_emacs '(let ((message-dont-reply-to-names
+ (test-visible-output "OUTPUT-FULL-PRED.raw"))'
+
+ notmuch_dir_sanitize < OUTPUT-FULL-PRED.raw > OUTPUT-FULL-PRED
+-head -7 OUTPUT-FULL-PRED > OUTPUT-PRED
++head -6 OUTPUT-FULL-PRED > OUTPUT-PRED
+
+ cat <<EOF > EXPECTED-PRED
+ From: Notmuch Test Suite <test_suite@notmuchmail.org>
+ To: Lars Kellogg-Stedman <lars@seas.harvard.edu>
+ Cc: notmuch@notmuchmail.org
+ Subject: Re: [notmuch] Working with Maildir storage?
+-In-Reply-To: <20091117203301.GV3165@dottiness.seas.harvard.edu>
+ Fcc: MAIL_DIR/sent
+ --text follows this line--
+ EOF
+@@ -59,14 +57,13 @@ test_emacs '(let ((message-dont-reply-to-names nil))
+ (test-visible-output "OUTPUT-FULL-NIL.raw"))'
+
+ notmuch_dir_sanitize < OUTPUT-FULL-NIL.raw > OUTPUT-FULL-NIL
+-head -7 OUTPUT-FULL-NIL > OUTPUT-NIL
++head -6 OUTPUT-FULL-NIL > OUTPUT-NIL
+
+ cat <<EOF > EXPECTED-NIL
+ From: Notmuch Test Suite <test_suite@notmuchmail.org>
+ To: Lars Kellogg-Stedman <lars@seas.harvard.edu>, Mikhail Gusarov <dottedmag@dottedmag.net>
+ Cc: notmuch@notmuchmail.org
+ Subject: Re: [notmuch] Working with Maildir storage?
+-In-Reply-To: <20091117203301.GV3165@dottiness.seas.harvard.edu>
+ Fcc: MAIL_DIR/sent
+ --text follows this line--
+ EOF
+diff --git a/test/emacs-reply.expected-output/notmuch-reply-duplicate-4 b/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
+index 836f77b1..44b8c7a6 100644
+--- a/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
++++ b/test/emacs-reply.expected-output/notmuch-reply-duplicate-4
+@@ -1,7 +1,6 @@
+ From: Notmuch Test Suite <test_suite@notmuchmail.org>
+ To: Sean Whitton <spwhitton@spwhitton.name>, 916811@bugs.debian.org, 916805@bugs.debian.org, 916807@bugs.debian.org, 916808@bugs.debian.org, 916809@bugs.debian.org, 916811@bugs.debian.org, 916867@bugs.debian.org, 916869@bugs.debian.org, 916872@bugs.debian.org, 916875@bugs.debian.org, 916876@bugs.debian.org
+ Subject: Re: [Pkg-emacsen-addons] Bug#916811: Increase severity to 'serious'
+-In-Reply-To: <87r2ecrr6x.fsf@zephyr.silentflame.com>
+ Fcc: MAIL_DIR/sent
+ --text follows this line--
+ Sean Whitton <spwhitton@spwhitton.name> writes:
+--
+2.41.0
+

base-commit: 51deacd8604b59aa434e944c73aecefd5183d13e
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Aug 2023 05:33
(address . andrew@trop.in)
7fd5cb4f55a0b76e4d71980aa9bc6064e9d3b9dd.camel@gmail.com
Am Dienstag, dem 15.08.2023 um 00:38 +0200 schrieb Arjan Adriaanse:
Toggle quote (2 lines)
> * gnu/packages/mail.scm (notmuch): Add patch.
> * gnu/packages/patches/notmuch-emacs-test-output.patch: Add file.
Also added the right line to gnu/local.mk, adapted the ChangeLog
accordingly, and pushed.

Thanks
L
L
Liliana Marie Prikler wrote on 15 Aug 2023 05:34
(address . andrew@trop.in)
4452c87fcb25ea76d5bf770e8911a05585523f66.camel@gmail.com
Am Dienstag, dem 15.08.2023 um 05:33 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (7 lines)
> Am Dienstag, dem 15.08.2023 um 00:38 +0200 schrieb Arjan Adriaanse:
> > * gnu/packages/mail.scm (notmuch): Add patch.
> > * gnu/packages/patches/notmuch-emacs-test-output.patch: Add file.
> Also added the right line to gnu/local.mk, adapted the ChangeLog
> accordingly, and pushed.
>
> Thanks
And marking as done…
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65298@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65298
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch