[PATCH emacs-team 0/2] fix emacs-emacsql and related packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Arjan Adriaanse
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Arjan Adriaanse
Severity
normal
A
A
Arjan Adriaanse wrote on 14 Aug 2023 16:54
(address . guix-patches@gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
cover.1692024757.git.arjan@adriaan.se
This updates emacs-emacsql and removes emacs-emacsql-sqlite3 to fix building
with Emacs 29. Tested by rebuilding dependent packages.

Arjan Adriaanse (2):
gnu: emacs-emacsql: Update to 3.1.1-1.29194a6.
gnu: Remove emacs-emacsql-sqlite3.

gnu/packages/emacs-xyz.scm | 55 +++-----------------------------------
1 file changed, 4 insertions(+), 51 deletions(-)


base-commit: 51deacd8604b59aa434e944c73aecefd5183d13e
--
2.41.0
A
A
Arjan Adriaanse wrote on 14 Aug 2023 16:56
[PATCH emacs-team 1/2] gnu: emacs-emacsql: Update to 3.1.1-1.29194a6.
(address . 65290@debbugs.gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
92438a4c1d278cd808dba2308cf86ef6dd2474d7.1692024757.git.arjan@adriaan.se
This commit fixes the check phase when building with Emacs 29.

* gnu/packages/emacs-xyz.scm (emacs-emacsql): Update to 3.1.1-1.29194a6.
[arguments]<#:phases>{remove-sqlite-builtin}: Remove phase.
---
gnu/packages/emacs-xyz.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1a44926729..6dc98183f8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21900,8 +21900,8 @@ (define-public emacs-finalize
(license license:unlicense)))
(define-public emacs-emacsql
- (let ((commit "e1baaf2f874df7f9259a8ecca978e03d3ddae5b5")
- (revision "0"))
+ (let ((commit "29194a63ede3ee24c7457c2fde03b0f1320ca4b1")
+ (revision "1"))
(package
(name "emacs-emacsql")
(version (git-version "3.1.1" revision commit))
@@ -21913,7 +21913,7 @@ (define-public emacs-emacsql
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0dvqs1jg5zqn0i3r67sn1a40h5rm961q9vxvmqxbgvdhkjvip8fn"))))
+ (base32 "14yj53xxqi3009bdj39k2fqwyc896yp2m7gdkgyv47wlkh1xwzxh"))))
(build-system emacs-build-system)
(arguments
(list
@@ -21929,12 +21929,6 @@ (define-public emacs-emacsql
(srfi srfi-26))
#:phases
#~(modify-phases %standard-phases
- (add-before 'install 'remove-sqlite-builtin
- ;; Current emacs 28.2 doesn't have sqlite feature and compilation
- ;; of this file fails. This phase should be removed, when emacs
- ;; package is updated to 29.
- (lambda _
- (delete-file "emacsql-sqlite-builtin.el")))
(add-before 'install 'patch-elisp-shell-shebangs
(lambda _
(substitute* (find-files "." "\\.el")
--
2.41.0
A
A
Arjan Adriaanse wrote on 14 Aug 2023 16:56
[PATCH emacs-team 2/2] gnu: Remove emacs-emacsql-sqlite3.
(address . 65290@debbugs.gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
6306bdcd879dbbd89dcc9f85bd765841a367972d.1692024757.git.arjan@adriaan.se
This package is obsolete since Emacs 29.

* gnu/packages/emacs-xyz.scm (emacs-emacsql-sqlite3): Delete variable.
(emacs-org-roam)[propagated-inputs]: Replace with emacs-emacsql.
---
gnu/packages/emacs-xyz.scm | 43 +-------------------------------------
1 file changed, 1 insertion(+), 42 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6dc98183f8..412ace373e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21966,47 +21966,6 @@ (define-public emacs-emacsql
object @code{nil} corresponds 1:1 with @code{NULL} in the database.")
(license license:gpl3+))))
-(define-public emacs-emacsql-sqlite3
- ;; This commit contains changes necessary for Sqlite 3.38+.
- (let ((commit "2113618732665f2112cb932a66c0e89c404d8777")
- (revision "1"))
- (package
- (name "emacs-emacsql-sqlite3")
- (version (git-version "1.0.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cireu/emacsql-sqlite3")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0r8svrd0d4cflx8a8gkynnhafcpv3ksn9rds8dhyx5yibximbzsw"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("emacs" "-Q" "--batch" "-L" "."
- "--load" "emacsql-sqlite3-test.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'embed-path-to-sqlite3
- (lambda _
- (substitute* "emacsql-sqlite3.el"
- (("\\(executable-find \"sqlite3\"\\)")
- (string-append "\"" (which "sqlite3") "\""))))))))
- (native-inputs
- (list emacs-ert-runner))
- (inputs
- (list sqlite))
- (propagated-inputs
- (list emacs-emacsql))
- (home-page "https://github.com/cireu/emacsql-sqlite3")
- (synopsis "EmacSQL backend for SQLite")
- (description "This is yet another EmacSQL backend for SQLite which uses
-official @command{sqlite3} executable to access SQL database.")
- (license license:gpl3+))))
-
(define-public emacs-closql
(package
(name "emacs-closql")
@@ -35269,7 +35228,7 @@ (define-public emacs-org-roam
(list texinfo))
(propagated-inputs
(list emacs-dash
- emacs-emacsql-sqlite3
+ emacs-emacsql
emacs-f
emacs-magit
emacs-org
--
2.41.0
L
L
Liliana Marie Prikler wrote on 15 Aug 2023 05:34
Re: [bug#65290] [PATCH emacs-team 0/2] fix emacs-emacsql and related packages
(name . Andrew Tropin)(address . andrew@trop.in)
63d03e9f9ac8f781175d2e16361a135516e11bd3.camel@gmail.com
Am Montag, dem 14.08.2023 um 16:54 +0200 schrieb Arjan Adriaanse:
Toggle quote (2 lines)
> This updates emacs-emacsql and removes emacs-emacsql-sqlite3 to fix
> building with Emacs 29.  Tested by rebuilding dependent packages.
Thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65290@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65290
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch