[PATCH] gnu: waybar: Update to 0.9.20.

  • Done
  • quality assurance status badge
Details
2 participants
  • dan
  • Christopher Baines
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20230814020916.3255-1-i@dan.games
* gnu/packages/wm.scm (waybar): Update to 0.9.20.
[arguments]<:configure-flags>: Disable download missing dependencies.
[inputs]: Add libevdev, pipewire and wireplumber.
* gnu/packages/wm.scm (waybar-experimental)
[arguments]<:configure-flags>: Disable download missing dependencies.
---
gnu/packages/wm.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index ae571965e6..3709c7c7b8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1894,7 +1894,7 @@ (define-public swaynotificationcenter
(define-public waybar
(package
(name "waybar")
- (version "0.9.18")
+ (version "0.9.20")
(source
(origin
(method git-fetch)
@@ -1903,22 +1903,27 @@ (define-public waybar
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "11yia2fs5a05jlbrdhxm26c2sgmbj3iwsk3bsqcvjvv3mlsrhxkf"))))
+ (base32 "07h5l7h7wmzqgg7fbp98khrxg2sq2s4ncp4fiiz1yg62r752idy4"))))
(build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "--wrap-mode=nodownload")))
(inputs (list date
fmt
gtk-layer-shell
gtkmm-3
jsoncpp
libdbusmenu
+ libevdev
libinput-minimal
libmpdclient
libnl
libxml2
+ pipewire
playerctl
pulseaudio
spdlog
- wayland))
+ wayland
+ wireplumber))
(native-inputs
(list `(,glib "bin") pkg-config scdoc wayland-protocols))
(home-page "https://github.com/Alexays/Waybar")
@@ -1960,7 +1965,8 @@ (define-public waybar-experimental
(package/inherit base
(name "waybar-experimental")
(arguments
- (list #:configure-flags #~(list "-Dexperimental=true")))
+ (list #:configure-flags #~(list "-Dexperimental=true"
+ "--wrap-mode=nodownload")))
(synopsis "Waybar with experimental features"))))
(define-public wlr-randr
@@ -3437,3 +3443,4 @@ (define-public velox
(description "velox is a simple window manager for Wayland based on swc.
It is inspired by dwm and xmonad.")
(license license:expat))))
+waybar

base-commit: e7b8edc74490ebd345ca3b518418a59d1d00abe2
--
2.41.0
C
C
Christopher Baines wrote on 29 Aug 2023 15:01
(name . dan)(address . i@dan.games)(address . 65279-done@debbugs.gnu.org)
87il8ygfw7.fsf@cbaines.net
dan <i@dan.games> writes:

Toggle quote (9 lines)
> * gnu/packages/wm.scm (waybar): Update to 0.9.20.
> [arguments]<:configure-flags>: Disable download missing dependencies.
> [inputs]: Add libevdev, pipewire and wireplumber.
> * gnu/packages/wm.scm (waybar-experimental)
> [arguments]<:configure-flags>: Disable download missing dependencies.
> ---
> gnu/packages/wm.scm | 15 +++++++++++----
> 1 file changed, 11 insertions(+), 4 deletions(-)

...

Toggle quote (9 lines)
> @@ -1960,7 +1965,8 @@ (define-public waybar-experimental
> (package/inherit base
> (name "waybar-experimental")
> (arguments
> - (list #:configure-flags #~(list "-Dexperimental=true")))
> + (list #:configure-flags #~(list "-Dexperimental=true"
> + "--wrap-mode=nodownload")))
> (synopsis "Waybar with experimental features"))))

Here I've changed this to the following:

+ (substitute-keyword-arguments (package-arguments base)
+ ((#:configure-flags flags '())
+ #~(cons "-Dexperimental=true"
+ #$flags))))

So now waybar-experimental will automatically inherit the configure
flags of waybar.

Toggle quote (6 lines)
> @@ -3437,3 +3443,4 @@ (define-public velox
> (description "velox is a simple window manager for Wayland based on swc.
> It is inspired by dwm and xmonad.")
> (license license:expat))))
> +waybar

I've removed this line and pushed to master as
005da27028ebab8998ce54c88683d809b3ceaf62.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTt7IhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd2XA//QouqtniHUSm79gm6i6FsUWwfiXiVvsMH
y7cX2XNJGUUG+UozJPPfVrBUsXgD6ya3PZg9M+9wDc5JdohfW63kRoojOSEt3xwo
3VKgMTYdljIdEi01prf5Q9kndsfYGuCFdjxpdv0W9fURJc12MxF/B7vm++aQ7PPJ
tIkZfsNfiHsP2EQqFlhL3AzxOgmD6wI03UvwjNtLpXlky4QiX0FbYFxMLL6nX7+E
lf05jlGF6PIhlYtfQseS9JmytV5E65qiSQKV70VlaZGSLpgn6PjERIyqIHGPgLom
fzSwyM2GLyCG/uOTXzGc630CtSqa4QA1q5gAwWjVXMobah4oPMM4ATye8Iz/6My6
q231csdW+uF3F11EXUxyUrFy0C0qn93nqqeJdDz+zruxD0VzpYsnmVs3OeFRO/0o
nYj12KtUQIPSfwEiDCb5ICnUi0ViW4F0jMwl4uA8+jVd5R+FU1rCYySrjr6GE9CT
2/9rG4EFP9NOsJQuSzz0iv721VFIrwqxgGNR8atGQlx8cg/9fikm2QRWlOWYKjMF
P+TaPOdDGuakfiFR9Vcv+p7Xh1/0nbwkPJnv2nAo6X5VdQnM7loA2zbYu3nOo2re
N48eNqudcnRNSYirSgthuDEXVyWQ0ryKKUJ8yxJfeKx79cdBYsxTcuZKHOLqXsnv
/GhKqMaFHfE=
=H1DL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65279@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65279
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch