(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
* gnu/packages/emacs-xyz.scm (emacs-notmuch-indicator): New variable.
---
Hi,
I thought of adding Protesilaos Stavrou's `emacs-notmuch-indicator' to Guix.
Hope this looks fine, cheers, Fabio.
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..bc68c341e8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30061,6 +30061,27 @@ (define-public emacs-helm-notmuch
real search.")
(license license:gpl3+)))
+(define-public emacs-notmuch-indicator
+ (package
+ (name "emacs-notmuch-indicator")
+ (version "1.0.1")
+ (home-page "https://git.sr.ht/~protesilaos/notmuch-indicator")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/notmuch-indicator-" version
+ ".tar"))
+ (sha256
+ (base32
+ "1n5k2ikk93mdwqqysf6l7gd8i6iazk8yvbqpf8xnz5zny248cc2x"))))
+ (build-system emacs-build-system)
+ (synopsis "Display a mode line indicator with @code{notmuch-count} output")
+ (description "This package renders an indicator with an email count of the
+@code{notmuch} index on the Emacs mode line. The underlying mechanism is that of
+@code{notmuch-count}, which is used to find the number of items that match the
+given search terms.")
+ (license license:gpl3+)))
+
(define-public emacs-notmuch-maildir
(package
(name "emacs-notmuch-maildir")
base-commit: be6f5edd445850720dfcec2642db643b84fc0645
--
2.41.0