[PATCH] gnu: pcsc-lite: Update to 2.0.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Arjan Adriaanse
  • Christina O'Donnell
  • Nicolas Goaziou
Owner
Somebody
Submitted by
Arjan Adriaanse
Severity
normal
A
A
Arjan Adriaanse wrote on 13 Aug 2023 01:57
(address . guix-patches@gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
2b6a8addb357e8ed05d5ff15546015aa2640b8a0.1691884641.git.arjan@adriaan.se
* gnu/packages/security-token.scm (pcsc-lite): Update to 2.0.0.
---
gnu/packages/security-token.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 3a0ed245ad..1a4a433554 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -236,14 +236,14 @@ (define-public softhsm
(define-public pcsc-lite
(package
(name "pcsc-lite")
- (version "1.9.8")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (string-append "https://pcsclite.apdu.fr/files/"
"pcsc-lite-" version ".tar.bz2"))
(sha256
(base32
- "12923c6l5qzga1xlcxvm0vzbqrxnxq1qgzlrxf2y5gpcaz2q0bah"))))
+ "0mlk32gpzmzjf5v8qn56lpyyba625jzzw8rkrmpyvr8h8nvf5hyn"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-usbdropdir=/var/lib/pcsc/drivers"

base-commit: eb25c2b3e204a36a97ec724defe8930757ab83c0
--
2.41.0
C
C
Christina O'Donnell wrote on 21 Apr 23:11 +0200
owner 65257 !
(address . control@debbugs.gnu.org)
e86b182e-0ed8-a076-e93e-1f644349fdfa@mutix.org
owner 65257 !
user guix
usertag 65257 + under-review
usertag 65257 + patch-review-hackers-list
quit
C
C
Christina O'Donnell wrote on 21 Apr 23:27 +0200
[PATCH v2 0/1] gnu: pcsc-lite: Update to 2.1.0.
(address . arjan@adriaan.se)
cover.1713734666.git.cdo@mutix.org
Hi,

Thanks for the patch. Sorry it's taken so long to get to you.

This looks good. I updated it to 2.1.0, which required a small change to get
it to work with polkit enabled. Otherweise the patch is as-is.

I've tested this against its major dependencies: keepassxc and gnupg and
they're building and working fine with my Yubikey.

I'm happy for this to be committed.

Kind regards,
Christina

Arjan Adriaanse (1):
gnu: pcsc-lite: Update to 2.1.0.

gnu/packages/security-token.scm | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)


base-commit: a1d711c92e119f6b5b8e99a620cdba92a4ca3bfb
--
2.41.0
C
C
Christina O'Donnell wrote on 21 Apr 23:27 +0200
[PATCH v2 1/1] gnu: pcsc-lite: Update to 2.1.0.
(address . arjan@adriaan.se)
e0489a76dba82842d13e57be2d18f66c14ec99d4.1713734666.git.cdo@mutix.org
From: Arjan Adriaanse <arjan@adriaan.se>

* gnu/packages/security-token.scm (pcsc-lite): Update to 2.1.0.

Reviewed-by: Christina O'Donnell <cdo@mutix.org>

Change-Id: I133fd056afb84259cf5cb1f3e9c664ac336e50b9
---
gnu/packages/security-token.scm | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 00a7f97582d..0da2d94ba6d 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -83,6 +83,7 @@ (define-module (gnu packages security-token)
#:use-module (gnu packages tex)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
@@ -240,24 +241,33 @@ (define-public softhsm
(define-public pcsc-lite
(package
(name "pcsc-lite")
- (version "1.9.8")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (string-append "https://pcsclite.apdu.fr/files/"
"pcsc-lite-" version ".tar.bz2"))
(sha256
(base32
- "12923c6l5qzga1xlcxvm0vzbqrxnxq1qgzlrxf2y5gpcaz2q0bah"))))
+ "1aimbddk6jx828xrw1vg2g82i11v55inhr9jqhmixj24qwfbdjl5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-usbdropdir=/var/lib/pcsc/drivers"
- "--disable-libsystemd")))
+ "--disable-libsystemd")
+ #:phases ,#~(modify-phases %standard-phases
+ (add-after 'unpack 'set-policy-dir
+ (lambda _
+ (substitute* "configure"
+ (("polkit_policy_dir=.*")
+ (string-append "polkit_policy_dir=\""
+ #$output "/share/polkit-1/actions\""))))))))
(native-inputs
(list flex
perl ;for pod2man
pkg-config))
(inputs
- (list python eudev))
+ (list python
+ eudev
+ polkit))
(home-page "https://pcsclite.apdu.fr/")
(synopsis "Middleware to access a smart card using PC/SC")
(description
--
2.41.0
N
N
Nicolas Goaziou wrote on 6 May 13:54 +0200
(name . Christina O'Donnell)(address . cdo@mutix.org)
87r0efyx3g.fsf@nicolasgoaziou.fr
Hello,

Christina O'Donnell <cdo@mutix.org> writes:

Toggle quote (6 lines)
> From: Arjan Adriaanse <arjan@adriaan.se>
>
> * gnu/packages/security-token.scm (pcsc-lite): Update to 2.1.0.
>
> Reviewed-by: Christina O'Donnell <cdo@mutix.org>

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65257@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65257
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch