package/inherit records lack location for version field

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Simon Tournier
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 12 Aug 2023 03:27
(name . bug-guix)(address . bug-guix@gnu.org)
87msyxkq1s.fsf@gmail.com
Hello Guix,

In the current code base, if you do:

Toggle snippet (8 lines)
(use-modules (guix package)
(gnu packages qt))

(package-field-location qtbase 'version)

=> #f

It returns #f. This means 'guix refresh -u base' fails like:

Toggle snippet (3 lines)
qtbase: updating from version 6.3.2 to version 6.5.2...

Now, package/inherit is bogus here, but the problems remains for other
packages, such as zxing-cpp-1.2.

--
Thanks,
Maxim
S
S
Simon Tournier wrote on 5 Sep 2023 16:38
86r0ncu1kt.fsf@gmail.com
Hi Maxim,

On Fri, 11 Aug 2023 at 21:27, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (9 lines)
> --8<---------------cut here---------------start------------->8---
> (use-modules (guix package)
> (gnu packages qt))
>
> (package-field-location qtbase 'version)
>
> => #f
> --8<---------------cut here---------------end--------------->8---

[...]

Toggle quote (3 lines)
> Now, package/inherit is bogus here, but the problems remains for other
> packages, such as zxing-cpp-1.2.


Cheers,
simon
M
M
Maxim Cournoyer wrote on 6 Sep 2023 22:43
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 65236-done@debbugs.gnu.org)
87y1hjowwq.fsf@gmail.com
Hi,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (20 lines)
> Hi Maxim,
>
> On Fri, 11 Aug 2023 at 21:27, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> --8<---------------cut here---------------start------------->8---
>> (use-modules (guix package)
>> (gnu packages qt))
>>
>> (package-field-location qtbase 'version)
>>
>> => #f
>> --8<---------------cut here---------------end--------------->8---
>
> [...]
>
>> Now, package/inherit is bogus here, but the problems remains for other
>> packages, such as zxing-cpp-1.2.
>
> I think it is fixed by <https://issues.guix.gnu.org/issue/65757>.

Installed with a small fix in d552c250.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65236@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65236
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch