lcsync and librecast updates

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 11 Aug 2023 23:06
(address . guix-patches@gnu.org)
87cyzte1bv.fsf@wireframe
There have been recent updates to librecast and lcsync. librecast should
release 0.7.x someday soon, so I will submit patches for the latest
release candidate to get the review process started. The lcsync 0.2.x
versions depend on librecast 0.7.x.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZNaixAAKCRDcUY/If5cW
qiBIAQCiFbP3F13gtc1YWlEav9MqXdbMoD9McLxCPny+dIX7nQD/SBI5Tm6EO3xf
W1hEUrrIAqUu7Esv9/Ga8nuBEiSw1As=
=J1Jg
-----END PGP SIGNATURE-----

V
V
vagrant wrote on 11 Aug 2023 23:11
[PATCH 1/2] gnu: librecast: Update to 0.7-RC3.
(address . 65233@debbugs.gnu.org)(address . vagrant@debian.org)
20230811211200.15605-1-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (librecast): Update to 0.7-RC3.
[arguments]: Drop 'remove-network-tests phase.
---
gnu/packages/networking.scm | 25 +++----------------------
1 file changed, 3 insertions(+), 22 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 542e93891c..a94e26dd10 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -489,7 +489,7 @@ (define-public libnice
(define-public librecast
(package
(name "librecast")
- (version "0.6.1")
+ (version "0.7-RC3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -498,7 +498,7 @@ (define-public librecast
(file-name (git-file-name name version))
(sha256
(base32
- "1kixnm7pn8345wp0klhnpw5x992cqbqx3bhc01j8xhqf6irlzdm3"))))
+ "06k5a84byj7md82a7idlqwricrjbmqxn3w1cjaarybiwd2jwqg80"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
@@ -507,26 +507,7 @@ (define-public librecast
(cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out"))))
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-before 'check 'remove-network-tests
- (lambda _
- ;; these tests require networking
- (delete-file "./test/0000-0010.c")
- (delete-file "./test/0000-0012.c")
- (delete-file "./test/0000-0013.c")
- (delete-file "./test/0000-0014.c")
- (delete-file "./test/0000-0015.c")
- (delete-file "./test/0000-0016.c")
- (delete-file "./test/0000-0018.c")
- (delete-file "./test/0000-0019.c")
- (delete-file "./test/0000-0021.c")
- (delete-file "./test/0000-0028.c")
- (delete-file "./test/0000-0036.c")
- (delete-file "./test/0000-0037.c")
- (delete-file "./test/0000-0038.c")
- (delete-file "./test/0000-0039.c")
- (delete-file "./test/0000-0040.c"))))))
+ #:test-target "test"))
(inputs (list libsodium lcrq))
(synopsis "IPv6 multicast library")
(description "Librecast is a C library which supports IPv6 multicast

base-commit: 19a7a824c35eae56ce56e2a460042fb7e2129234
--
2.39.2
V
V
vagrant wrote on 11 Aug 2023 23:12
[PATCH 2/2] gnu: lcsync: Update to 0.2.1.
(address . 65233@debbugs.gnu.org)(address . vagrant@debian.org)
20230811211200.15605-2-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcsync): Update to 0.2.1.
[arguments]: #:configure-flags Pass --prefix.
Drop 'remove-network-tests and 'remove-immintrin.h phase.
Add 'use-prefix-from-configure-in-doc-makefile phase.
[inputs]: Add lcrq.
[native-inputs]: Remove simde.
---
gnu/packages/networking.scm | 40 +++++++++++++------------------------
1 file changed, 14 insertions(+), 26 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a94e26dd10..a97a3efb12 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -289,7 +289,7 @@ (define-public lcrq
(define-public lcsync
(package
(name "lcsync")
- (version "0.0.1")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -298,45 +298,33 @@ (define-public lcsync
(file-name (git-file-name name version))
(sha256
(base32
- "0s038b4xg9nlzhrganzjyfvc6n6cgd6kilnpik4axp62j2n5q11q"))))
+ "0bsd3dkir2i647nmrmyb7skbv16v0f6f3gfwkpxz8g42978dlms5"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
+ #:configure-flags
+ (list
+ (string-append "--prefix="
+ (assoc-ref %outputs "out")))
#:make-flags (let ((target ,(%current-target-system)))
(list ,(string-append "CC="
- (cc-for-target))
- ;; avoid running setcap in the install process
- "SETCAP_PROGRAM=true"
- (string-append "prefix="
- (assoc-ref %outputs "out"))))
+ (cc-for-target))))
#:test-target "test"
#:phases (modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (add-before 'check 'remove-network-tests
+ (add-after 'unpack 'use-prefix-from-configure-in-doc-makefile
+ ;; Use prefix from configure. Fixed upstream:
+ ;; https://codeberg.org/librecast/lcsync/commit/4ba00f6
+ ;; XXX: Remove for 0.2.2+
(lambda _
- ;; these tests require networking
- (delete-file "./test/0000-0027.c")
- (delete-file "./test/0000-0049.c")
- (delete-file "./test/0000-0074.c")))
- (add-after 'unpack 'remove-immintrin.h
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makefile"
- (("CFLAGS :=")
- (string-append "CFLAGS := -I" (search-input-directory
- inputs "include/simde"))))
- (substitute* (find-files "src")
- ((".*immintrin\\.h.*")
- (string-append "#include <simde-features.h>\n"
- "#include <x86/ssse3.h>\n"))
- (("__m128i") "simde__m128i"))))
+ (substitute* "doc/Makefile.in"
+ (("PREFIX .= /usr/local") "PREFIX ?= @prefix@"))))
(add-before 'build 'add-library-paths
(lambda* (#:key inputs #:allow-other-keys)
(let* ((librecast (assoc-ref inputs "librecast")))
(substitute* (list "./src/Makefile" "./test/Makefile")
(("-llibrecast")
(string-append "-L" librecast "/lib -llibrecast")))))))))
- (inputs (list librecast libsodium))
- (native-inputs (list simde))
+ (inputs (list lcrq librecast libsodium))
(home-page "https://librecast.net/lcsync.html")
(synopsis "Librecast file and data syncing tool")
(description
--
2.39.2
V
V
vagrant wrote on 22 Aug 2023 22:31
[PATCH 1/2] gnu: librecast: Update to 0.7.0.
(address . 65233@debbugs.gnu.org)(address . vagrant@debian.org)
20230822203120.295325-1-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (librecast): Update to 0.7.0.
[arguments]: Drop 'remove-network-tests phase.
---
gnu/packages/networking.scm | 25 +++----------------------
1 file changed, 3 insertions(+), 22 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 04461fec2d..2b2e2bd4a5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -487,7 +487,7 @@ (define-public libnice
(define-public librecast
(package
(name "librecast")
- (version "0.6.1")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -496,7 +496,7 @@ (define-public librecast
(file-name (git-file-name name version))
(sha256
(base32
- "1kixnm7pn8345wp0klhnpw5x992cqbqx3bhc01j8xhqf6irlzdm3"))))
+ "0y0km0fv39m3i227pyg7fcr7d94gbji51fkcywqyrjgmk4j1hp1n"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
@@ -505,26 +505,7 @@ (define-public librecast
(cc-for-target))
(string-append "PREFIX="
(assoc-ref %outputs "out"))))
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-before 'check 'remove-network-tests
- (lambda _
- ;; these tests require networking
- (delete-file "./test/0000-0010.c")
- (delete-file "./test/0000-0012.c")
- (delete-file "./test/0000-0013.c")
- (delete-file "./test/0000-0014.c")
- (delete-file "./test/0000-0015.c")
- (delete-file "./test/0000-0016.c")
- (delete-file "./test/0000-0018.c")
- (delete-file "./test/0000-0019.c")
- (delete-file "./test/0000-0021.c")
- (delete-file "./test/0000-0028.c")
- (delete-file "./test/0000-0036.c")
- (delete-file "./test/0000-0037.c")
- (delete-file "./test/0000-0038.c")
- (delete-file "./test/0000-0039.c")
- (delete-file "./test/0000-0040.c"))))))
+ #:test-target "test"))
(inputs (list libsodium lcrq))
(synopsis "IPv6 multicast library")
(description "Librecast is a C library which supports IPv6 multicast

base-commit: db02fcde386892b3a054d64403a4a5bfa1b7fce8
--
2.39.2
V
V
vagrant wrote on 22 Aug 2023 22:31
[PATCH 2/2] gnu: lcsync: Update to 0.2.1.
(address . 65233@debbugs.gnu.org)(address . vagrant@debian.org)
20230822203120.295325-2-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcsync): Update to 0.2.1.
[arguments]: #:configure-flags Pass --prefix.
Drop 'remove-network-tests and 'remove-immintrin.h phase.
Add 'use-prefix-from-configure-in-doc-makefile phase.
[inputs]: Add lcrq.
[native-inputs]: Remove simde.
---
gnu/packages/networking.scm | 40 +++++++++++++------------------------
1 file changed, 14 insertions(+), 26 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 2b2e2bd4a5..50de871e82 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -289,7 +289,7 @@ (define-public lcrq
(define-public lcsync
(package
(name "lcsync")
- (version "0.0.1")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -298,45 +298,33 @@ (define-public lcsync
(file-name (git-file-name name version))
(sha256
(base32
- "0s038b4xg9nlzhrganzjyfvc6n6cgd6kilnpik4axp62j2n5q11q"))))
+ "0bsd3dkir2i647nmrmyb7skbv16v0f6f3gfwkpxz8g42978dlms5"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
+ #:configure-flags
+ (list
+ (string-append "--prefix="
+ (assoc-ref %outputs "out")))
#:make-flags (let ((target ,(%current-target-system)))
(list ,(string-append "CC="
- (cc-for-target))
- ;; avoid running setcap in the install process
- "SETCAP_PROGRAM=true"
- (string-append "prefix="
- (assoc-ref %outputs "out"))))
+ (cc-for-target))))
#:test-target "test"
#:phases (modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (add-before 'check 'remove-network-tests
+ (add-after 'unpack 'use-prefix-from-configure-in-doc-makefile
+ ;; Use prefix from configure. Fixed upstream:
+ ;; https://codeberg.org/librecast/lcsync/commit/4ba00f6
+ ;; XXX: Remove for 0.2.2+
(lambda _
- ;; these tests require networking
- (delete-file "./test/0000-0027.c")
- (delete-file "./test/0000-0049.c")
- (delete-file "./test/0000-0074.c")))
- (add-after 'unpack 'remove-immintrin.h
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makefile"
- (("CFLAGS :=")
- (string-append "CFLAGS := -I" (search-input-directory
- inputs "include/simde"))))
- (substitute* (find-files "src")
- ((".*immintrin\\.h.*")
- (string-append "#include <simde-features.h>\n"
- "#include <x86/ssse3.h>\n"))
- (("__m128i") "simde__m128i"))))
+ (substitute* "doc/Makefile.in"
+ (("PREFIX .= /usr/local") "PREFIX ?= @prefix@"))))
(add-before 'build 'add-library-paths
(lambda* (#:key inputs #:allow-other-keys)
(let* ((librecast (assoc-ref inputs "librecast")))
(substitute* (list "./src/Makefile" "./test/Makefile")
(("-llibrecast")
(string-append "-L" librecast "/lib -llibrecast")))))))))
- (inputs (list librecast libsodium))
- (native-inputs (list simde))
+ (inputs (list lcrq librecast libsodium))
(home-page "https://librecast.net/lcsync.html")
(synopsis "Librecast file and data syncing tool")
(description
--
2.39.2
V
V
Vagrant Cascadian wrote on 24 Aug 2023 00:02
lcsync and librecast updates
(address . 65233@debbugs.gnu.org)(address . control@debbugs.gnu.org)
878ra1e7tc.fsf@wireframe
retitle 65233 lcsync and librecast updates
thanks

Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
removing "WIP" from the title; these are worthy of merging, I hope. :)

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZOaB7wAKCRDcUY/If5cW
qj7ZAQD4DpdirNWLxzBcv9ghaC+ZodF/XzSEsKY+Bix6EJt6UwD9EwBhTL4vZyB1
HKr53vfzjo59KSByu7vUYW12d0jbwws=
=LlGY
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 29 Aug 2023 14:56
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 65233-done@debbugs.gnu.org)
874jkihurm.fsf@cbaines.net
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (3 lines)
> Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
> removing "WIP" from the title; these are worthy of merging, I hope. :)

This looks good to me, I've pushed it to master as
5f672aaa0ca7e2c5775c8950fa1627ac419e557e.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTt6v1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcKmQ/8Dhlj+Clw1gYQTUFISveZ7k5kPhK+9gY9
yQ4XXoOC8a7sl22C6YduYgvtjNtPgGhfaIwA4D6z93cYAwZJdUQvlk7UFx5ARaUC
Zfpd7SciWg8GBulmIcAP76miEOtDa+a7zZW0BxFClXYr4gkTyK6CcJoEAafwuqe+
H1aI01Mqv6kIdF0Vn/TxsJb63LyXsFYlRYg2PDsVDRO/jwNq+6KS72mOBGyGj8ee
qWDaYRFSdwZK1Xed8fMaL5WDv272XhYI6eOa9SNwEW1lu2blnnxVk0yYN0DNlvKB
puIp5FQQyFUJdapfWDY9wSq0FgWjkwGK03J2jXmhkxeZP2QIiPA1WKlBJ6wn+d1v
X/nj/9Z76k5HCl4oCmd1Jc52mvanc9u0Kapepz3L3f5DY2IMwNrm1j3FmwaVs3Kr
mbHrKc7wcYnbYZxKbOJ/VYuJBGA6LEgA6WSQtSjXXdhBMrAmsJoZHD0XDjnmsOGs
s7PRl0qtOpycXFGw5fdFl4+GEk88d73AbrOSR4aL27Gui+IXzTb+as1n3MwVWhto
v2mYZdrjPqSLLvTNnN0NUB2vQtAG+gJzyQ2CIJiYwXD1mDrVKoGl3bD94LwY0mzc
wyModF9WidGpkEY9O+uZacXcnNGQbBkewfjPsw6pqgStxlBna9VWC+UlQzLKrsux
xfetYGq5sg0=
=1lDS
-----END PGP SIGNATURE-----

Closed
V
V
Vagrant Cascadian wrote on 29 Aug 2023 19:40
(name . Christopher Baines)(address . mail@cbaines.net)(address . 65233@debbugs.gnu.org)
87zg29vja5.fsf@wireframe
On 2023-08-29, Christopher Baines wrote:
Toggle quote (8 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
>> removing "WIP" from the title; these are worthy of merging, I hope. :)
>
> This looks good to me, I've pushed it to master as
> 5f672aaa0ca7e2c5775c8950fa1627ac419e557e.

Thanks!

It looks like you ended up merging the old librecast 0.7-RC3 patch,
rather than the 0.7.0 patch I submitted later. I apparently forgot to
mark it as a v2 patch, which maybe tripped you up.

Would it be ok if I pushed the newer version or would you be able to?

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZO4togAKCRDcUY/If5cW
qt0OAQCgc/FN0GWR0Il/DumicoZK641uinaZerRVzUErREXrvAD/f5K2hiqXnUwU
yiGKY1oTJEpZfwAKb8WXF9MKECn1pQw=
=0+cT
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 29 Aug 2023 20:04
(name . Christopher Baines)(address . mail@cbaines.net)(address . 65233@debbugs.gnu.org)
87wmxdvi6k.fsf@wireframe
On 2023-08-29, Vagrant Cascadian wrote:
Toggle quote (17 lines)
> On 2023-08-29, Christopher Baines wrote:
>> Vagrant Cascadian <vagrant@debian.org> writes:
>>
>>> Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
>>> removing "WIP" from the title; these are worthy of merging, I hope. :)
>>
>> This looks good to me, I've pushed it to master as
>> 5f672aaa0ca7e2c5775c8950fa1627ac419e557e.
>
> Thanks!
>
> It looks like you ended up merging the old librecast 0.7-RC3 patch,
> rather than the 0.7.0 patch I submitted later. I apparently forgot to
> mark it as a v2 patch, which maybe tripped you up.
>
> Would it be ok if I pushed the newer version or would you be able to?

I just went ahead and pushed c61c499c59109f6094384ee205c98034d759b600 as
a follow-up to update librecast to 0.7.0.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZO4zMwAKCRDcUY/If5cW
qt8mAQC6OiiZxtMOPpo8VBhgu7hqN3otUsnCShfNPTwjwjjJnQD8Dj7Zuwulhsyw
cHJm3yegK7r1TuJhTYMSteYe5jODqAA=
=VQEG
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 31 Aug 2023 14:30
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 65233@debbugs.gnu.org)
87bkenfl3m.fsf@cbaines.net
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (22 lines)
> [[PGP Signed Part:Signature made by expired key DC518FC87F9716AA Vagrant Cascadian <vagrant@aikidev.net>]]
> On 2023-08-29, Vagrant Cascadian wrote:
>> On 2023-08-29, Christopher Baines wrote:
>>> Vagrant Cascadian <vagrant@debian.org> writes:
>>>
>>>> Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
>>>> removing "WIP" from the title; these are worthy of merging, I hope. :)
>>>
>>> This looks good to me, I've pushed it to master as
>>> 5f672aaa0ca7e2c5775c8950fa1627ac419e557e.
>>
>> Thanks!
>>
>> It looks like you ended up merging the old librecast 0.7-RC3 patch,
>> rather than the 0.7.0 patch I submitted later. I apparently forgot to
>> mark it as a v2 patch, which maybe tripped you up.
>>
>> Would it be ok if I pushed the newer version or would you be able to?
>
> I just went ahead and pushed c61c499c59109f6094384ee205c98034d759b600 as
> a follow-up to update librecast to 0.7.0.

Apologies for this, I didn't check that I'd got the right patches before
pushing. The slightly longer story is that I cherry picked these from
the guix-patches repository [1], but a bug in QA meant that it hadn't
been updating the branches, so I cherry picked the earlier version of
the patch.

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTwiG1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe+cA//ab+7b7Mq277nkvfrQoc5PSPixyGlFjGu
dQwGLRAIYarP1cFkvW1knVMRdHcElFm0RCI0q3Nl7LyP6WxWHaYymLfsKGYTIdsi
5VbftulI778XT+cbb0pY6q9WFLLSYLml5nxW7UP4OzI2HUoK+/RGB0OtMAwig2bl
f5LylxLBi2l95EJ635SMdVpJz7kdXXT3iXqMjp/7Q0s52iQzx37AhXAFURCWNj9l
GmRk/+LUNfXmAe+IAMjDK9hqrQr8AflWb5X6raL+Q8XmrWlpM/cg0fv5rFSsURby
UzLjy19W2Vi5Nk6KRbYWSXFgERxnIKn0dLWbfwmFwANsZIscNVoKSQguJ7LLK+rt
P1RJY1G1uWIxsgFfcyjDiD1NdQA3++ivQHvejAZbOvTaTcjqQJD7e3y2VMMu8Qwx
lg1L1hn1YFFZ+C1DsGjMuxhWzERs/EfrSh3qjC9Gsl4IG00SAyT9TOoVGa75LzWz
FPFtZfZs4lj/4m+DbhdGqSHr4FJR7TzBv8GaHJW7vLAGYywZ8XrZTnp4884ypt/j
EbxlE6/9ofuxgdOLEEN+6Y+75ZfSamDGl9IpaJOBPP0y2J1ziBrZ1dmfOgN9JBge
UMlnOR2XKc4yWDuIP9DEKbc+C+SUhFWgbwygaehT6gC/txVl7tyLrQOmpvtnu7xB
2IAVo3h1Gx8=
=Ie7m
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 31 Aug 2023 23:52
(name . Christopher Baines)(address . mail@cbaines.net)(address . 65233@debbugs.gnu.org)
87pm32ubfh.fsf@wireframe
On 2023-08-31, Christopher Baines wrote:
Toggle quote (27 lines)
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> [[PGP Signed Part:Signature made by expired key DC518FC87F9716AA Vagrant Cascadian <vagrant@aikidev.net>]]
>> On 2023-08-29, Vagrant Cascadian wrote:
>>> On 2023-08-29, Christopher Baines wrote:
>>>> Vagrant Cascadian <vagrant@debian.org> writes:
>>>>
>>>>> Both lcsync 0.2.1 and librecast 0.7.0 have upstream releases now, thus
>>>>> removing "WIP" from the title; these are worthy of merging, I hope. :)
>>>>
>>>> This looks good to me, I've pushed it to master as
>>>> 5f672aaa0ca7e2c5775c8950fa1627ac419e557e.
>>>
>>> Thanks!
>>>
>>> It looks like you ended up merging the old librecast 0.7-RC3 patch,
>>> rather than the 0.7.0 patch I submitted later. I apparently forgot to
>>> mark it as a v2 patch, which maybe tripped you up.
>>>
>>> Would it be ok if I pushed the newer version or would you be able to?
>>
>> I just went ahead and pushed c61c499c59109f6094384ee205c98034d759b600 as
>> a follow-up to update librecast to 0.7.0.
>
> Apologies for this, I didn't check that I'd got the right patches before
> pushing.

No worries, it was easy enough to fix. :)

Toggle quote (7 lines)
> The slightly longer story is that I cherry picked these from
> the guix-patches repository [1], but a bug in QA meant that it hadn't
> been updating the branches, so I cherry picked the earlier version of
> the patch.
>
> 1: https://git.guix-patches.cbaines.net/guix-patches/

This is so tremendously useful, even with a few glitches now and then! I
only recently learned about it!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHQEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPELogAKCRDcUY/If5cW
qlbkAP9P8z0FelMVyplwTDkMa0bes0c7qEX/eO+KcUn6h44+BwD2PbfJdHQqBfYA
j1a1tMk2whUU4763RAuDvfdmnJHPAw==
=bw93
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 65233@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65233
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch