[PATCH] gnu: scsh: Fix version number and use gexps.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Andrew Whatson
Owner
unassigned
Submitted by
Andrew Whatson
Severity
normal
A
A
Andrew Whatson wrote on 11 Aug 2023 13:39
(address . guix-patches@gnu.org)(name . Andrew Whatson)(address . whatson@tailcall.au)
2ba7955e538aada24450172a8f05d3b854e6a76d.1691753983.git.whatson@tailcall.au
* gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
Use git-version. Correct base version number to 0.7.
[arguments]: Use gexps and remove trailing #t in phases.
---
gnu/packages/shells.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..ca0f4c9ee0 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -602,11 +602,11 @@ (define-public xonsh
(license license:bsd-2)))
(define-public scsh
- (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
- (revision "1"))
+ (let ((commit "4acf6e4ed7b65b46186ef0c9c2a1e10bef8dc052")
+ (revision "0"))
(package
(name "scsh")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (version (git-version "0.7" revision commit))
(source
(origin
(method git-fetch)
@@ -616,22 +616,22 @@ (define-public scsh
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+ "1czrp808v5gs0ci5lmkp3wr3gfkrb3vd5b2iw2hz1bpqgaf6bxpv"))
(patches (search-patches "scsh-nonstring-search-path.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'replace-rx
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((rx (assoc-ref inputs "scheme48-rx"))
- (rxpath (string-append rx "/share/scheme48-"
- ,(package-version scheme48)
+ (list
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'replace-rx
+ (lambda _
+ (let ((rxpath (string-append #$scheme48-rx
+ "/share/scheme48-"
+ #$(package-version scheme48)
"/rx")))
- (delete-file-recursively "rx")
- (symlink rxpath "rx"))
- #t)))))
+ (delete-file-recursively "rx")
+ (symlink rxpath "rx")))))))
(inputs
(list scheme48 scheme48-rx))
(native-inputs

base-commit: ad4520b92662e42d7d0b1e648b2068300dbb95c8
--
2.41.0
A
A
Andrew Whatson wrote on 11 Aug 2023 13:48
[PATCH v2] gnu: scsh: Fix version number and use gexps.
(name . Andrew Whatson)(address . whatson@tailcall.au)
0380706921f8f64cf116af4f7479d6dfebb951ab.1691754518.git.whatson@tailcall.au
* gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
Use git-version. Correct base version number to 0.7.
[source]: Use git-file-name.
[arguments]: Use gexps and remove trailing #t in phases.
---
gnu/packages/shells.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..62b682496e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -602,36 +602,36 @@ (define-public xonsh
(license license:bsd-2)))
(define-public scsh
- (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
- (revision "1"))
+ (let ((commit "4acf6e4ed7b65b46186ef0c9c2a1e10bef8dc052")
+ (revision "0"))
(package
(name "scsh")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (version (git-version "0.7" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/scheme/scsh")
(commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+ "1czrp808v5gs0ci5lmkp3wr3gfkrb3vd5b2iw2hz1bpqgaf6bxpv"))
(patches (search-patches "scsh-nonstring-search-path.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'replace-rx
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((rx (assoc-ref inputs "scheme48-rx"))
- (rxpath (string-append rx "/share/scheme48-"
- ,(package-version scheme48)
+ (list
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'replace-rx
+ (lambda _
+ (let ((rxpath (string-append #$scheme48-rx
+ "/share/scheme48-"
+ #$(package-version scheme48)
"/rx")))
- (delete-file-recursively "rx")
- (symlink rxpath "rx"))
- #t)))))
+ (delete-file-recursively "rx")
+ (symlink rxpath "rx")))))))
(inputs
(list scheme48 scheme48-rx))
(native-inputs

base-commit: ad4520b92662e42d7d0b1e648b2068300dbb95c8
--
2.41.0
L
L
Ludovic Courtès wrote on 12 Aug 2023 23:14
Re: bug#65226: [PATCH] gnu: scsh: Fix version number and use gexps.
(name . Andrew Whatson)(address . whatson@tailcall.au)(address . 65226-done@debbugs.gnu.org)
87zg2warpo.fsf@gnu.org
Hi,

Andrew Whatson <whatson@tailcall.au> skribis:

Toggle quote (5 lines)
> * gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
> Use git-version. Correct base version number to 0.7.
> [source]: Use git-file-name.
> [arguments]: Use gexps and remove trailing #t in phases.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65226@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65226
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch