[PATCH] gnu: Add r-partr2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
f97d9250e7fb89e17bf830d12ea2e356a2438d8b.1691663315.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-partr2): New variable.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b847c9a5d7..29f5403702 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -947,6 +947,34 @@ (define-public r-numbat
solely on the donor scRNA-data data (for example, 10x Cell Ranger output).")
(license license:expat))))
+(define-public r-partr2
+ (package
+ (name "r-partr2")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "partR2" version))
+ (sha256
+ (base32
+ "06ky0hhrq0mcsn9rwrzvwn0rrjj0l8rxs0hqp10668gdq5hjk8bn"))))
+ (properties `((upstream-name . "partR2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-ggplot2
+ r-lme4
+ r-magrittr
+ r-pbapply
+ r-purrr
+ r-rlang
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mastoffel/partR2")
+ (synopsis "Partitioning R2 in GLMMs")
+ (description
+ "An R tool for estimating and partitioning R2 in GLMMs based on predictor variance.")
+ (license license:gpl2+)))
+
(define-public r-p2data
(let ((commit "7d4c0e17d7899f9d9b08ab2bf455abe150912f4c")
(revision "1"))

base-commit: 997b38badaee20a1c60411e5e599e260e47785ec
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 65201-done@debbugs.gnu.org)
87ttt65xza.fsf@elephly.net
Thanks for the patch. I relocated the package to cran.scm and adjusted
the description.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65201@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65201
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help