(address . guix-patches@gnu.org)
* gnu/packages/gl.scm (mesa) [native-search-paths]: Export XDG_DATA_DIRS.
According to
Vulkan loader search for manifest files in several directories. Some of them
are in the $HOME directory, some of them are set during compile-time. We
don't raelly want vulkan-loader to depend on mesa during compile-time, since
we couldn't assume that mesa is the only package providing Vulkan drivers.
Thus, it's better for us to export XDG_DATA_DIRS in mesa, so that when both
packages are installed, Vulkan loader could find the corresponding Vulkan
drivers by environment varaible.
---
gnu/packages/gl.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
Toggle diff (29 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index b53b42a9ba..583cd5a945 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2023 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -518,7 +519,11 @@ (define-public mesa
;; Ensure the Mesa VDPAU drivers can be found.
(variable "VDPAU_DRIVER_PATH")
(separator #f)
- (files '("lib/vdpau")))))
+ (files '("lib/vdpau")))
+ (search-path-specification
+ ;; Ensure the Vulkan drivers can be found by Vulkan loader.
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))))
(home-page "https://mesa3d.org/")
(synopsis "OpenGL and Vulkan implementations")
(description "Mesa is a free implementation of the OpenGL and Vulkan
base-commit: 4547bc6fa3142dca77f7fc912368aeff31bd6e53
--
2.41.0