* gnu/packages/patches/spdlog-fix-tests.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/logging.scm (spdlog)[source]: Use patch.
---
gnu/local.mk | 1 +
gnu/packages/logging.scm | 1 +
gnu/packages/patches/spdlog-fix-tests.patch | 26 +++++++++++++++++++++
3 files changed, 28 insertions(+)
create mode 100644 gnu/packages/patches/spdlog-fix-tests.patch
Toggle diff (58 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 77707127a7..af5eea1791 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1961,6 +1961,7 @@ dist_patch_DATA = \
%D%/packages/patches/source-highlight-gcc-compat.patch \
%D%/packages/patches/softhsm-fix-openssl3-tests.patch \
%D%/packages/patches/spectre-meltdown-checker-externalize-fwdb.patch \
+ %D%/packages/patches/spdlog-fix-tests.patch \
%D%/packages/patches/spectre-meltdown-checker-find-kernel.patch \
%D%/packages/patches/sphinxbase-fix-doxygen.patch \
%D%/packages/patches/sssd-system-directories.patch \
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index abeb3fdd5c..c204a013b4 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -221,6 +221,7 @@ (define-public spdlog
(url "https://github.com/gabime/spdlog")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "spdlog-fix-tests.patch"))
(sha256
(base32 "0yyncv6wjs5rqm76rkqyxpfbsingk1dq5zfcqhy1a7fpw8xdl53k"))))
(build-system cmake-build-system)
diff --git a/gnu/packages/patches/spdlog-fix-tests.patch b/gnu/packages/patches/spdlog-fix-tests.patch
new file mode 100644
index 0000000000..0eaf1d485d
--- /dev/null
+++ b/gnu/packages/patches/spdlog-fix-tests.patch
@@ -0,0 +1,26 @@
+Remove after next release and package update:
+https://github.com/gabime/spdlog/commit/2ee8bac78e6525a8ad9a9196e65d502ce390d83a
+
+From 2ee8bac78e6525a8ad9a9196e65d502ce390d83a Mon Sep 17 00:00:00 2001
+From: xvitaly <vitaly@easycoding.org>
+Date: Sun, 23 Jul 2023 10:15:25 +0200
+Subject: [PATCH] Added missing square bracket to fix the level_to_string_view
+ test. (#2827)
+
+---
+ tests/test_misc.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_misc.cpp b/tests/test_misc.cpp
+index 9f3cb1744..6199641ff 100644
+--- a/tests/test_misc.cpp
++++ b/tests/test_misc.cpp
+@@ -43,7 +43,7 @@ TEST_CASE("log_levels", "[log_levels]")
+ REQUIRE(log_info("Hello", spdlog::level::trace) == "Hello");
+ }
+
+-TEST_CASE("level_to_string_view", "[convert_to_string_view")
++TEST_CASE("level_to_string_view", "[convert_to_string_view]")
+ {
+ REQUIRE(spdlog::level::to_string_view(spdlog::level::trace) == "trace");
+ REQUIRE(spdlog::level::to_string_view(spdlog::level::debug) == "debug");
--
2.41.0