(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundationdevices.com)
* gnu/packages/ntp.scm (ntp)[inputs]: Use `target-linux?' instead of
the manual string comparison as it would not add the libcap input
correctly when cross-compiling as the platform ends in `-linux-gnu'
unlike the system string which ends in `-linux'.
Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
gnu/packages/ntp.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
Toggle diff (16 lines)
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 1a72efbc79..4ab8ab6631 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -139,8 +139,7 @@ (define-public ntp
libevent
;; Build with POSIX capabilities support on GNU/Linux. This allows
;; 'ntpd' to run as non-root (when invoked with '-u'.)
- (if (string-suffix? "-linux"
- (or (%current-target-system) (%current-system)))
+ (if (target-linux?)
(list libcap)
'())))
(arguments
--
2.34.1