[PATCH] gnu: Add libmodbus.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 2023 18:19
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230805161921.10571-1-monego@posteo.net
* gnu/packages/engineering.scm (libmodbus): New variable.
---
gnu/packages/engineering.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b5b4ad1b10..87e0b0e396 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1518,6 +1518,27 @@ (define-public sterm
(home-page "https://github.com/wentasah/sterm")
(license license:gpl3+)))
+(define-public libmodbus
+ (package
+ (name "libmodbus")
+ (version "3.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stephane/libmodbus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nbpk1n56kclab8fl32dxi46v2bwax3gfk1zkc796srm7vj42sbv"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Library for the Modbus protocol")
+ (description "@code{libmodbus} is a library to send/receive data with a
+device which respects the Modbus protocol. This library can use a serial port
+or an Ethernet connection.")
+ (home-page "https://libmodbus.org/")
+ (license license:lgpl2.1+)))
(define-public harminv
(package
(name "harminv")
--
2.34.1
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:51
(name . Vinicius Monego)(address . monego@posteo.net)(address . 65100-done@debbugs.gnu.org)
87fs3sf7jo.fsf@gmail.com
Hi,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/engineering.scm (libmodbus): New variable.

Installed, thanks for contributing!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65100@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65100
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch