[PATCH] gnu: Add libmseed.

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 18:18 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230805161837.10391-1-monego@posteo.net
* gnu/packages/geo.scm (libmseed): New variable.
---
gnu/packages/geo.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index cce4f2518d..a581495784 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1779,6 +1779,34 @@ (define-public libspatialindex
")
(license license:expat)))
+(define-public libmseed
+ (package
+ (name "libmseed")
+ (version "3.0.17")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EarthScope/libmseed")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "090xqcm9485vy6fbs2d1nd56fyy6mwh9kfflmflqqf4ckvaiskp6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://earthscope.github.io/libmseed/")
+ (synopsis "Library for the miniSEED data format")
+ (description "The miniSEED library provides a framework for manipulation
+of SEED data records, a format for commonly used for seismological time
+series and related data. The library includes the functionality to read
+and write data records, in addition to reconstructing time series
+from multiple records.")
+ (license license:asl2.0)))
+
(define-public python-rtree
(package
(name "python-rtree")
--
2.34.1
?