[PATCH] gnu: Add libmseed.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 2023 18:18
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230805161837.10391-1-monego@posteo.net
* gnu/packages/geo.scm (libmseed): New variable.
---
gnu/packages/geo.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index cce4f2518d..a581495784 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1779,6 +1779,34 @@ (define-public libspatialindex
")
(license license:expat)))
+(define-public libmseed
+ (package
+ (name "libmseed")
+ (version "3.0.17")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EarthScope/libmseed")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "090xqcm9485vy6fbs2d1nd56fyy6mwh9kfflmflqqf4ckvaiskp6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://earthscope.github.io/libmseed/")
+ (synopsis "Library for the miniSEED data format")
+ (description "The miniSEED library provides a framework for manipulation
+of SEED data records, a format for commonly used for seismological time
+series and related data. The library includes the functionality to read
+and write data records, in addition to reconstructing time series
+from multiple records.")
+ (license license:asl2.0)))
+
(define-public python-rtree
(package
(name "python-rtree")
--
2.34.1
M
M
Mathieu Othacehe wrote on 14 Oct 2023 10:29
(name . Vinicius Monego)(address . monego@posteo.net)(address . 65099@debbugs.gnu.org)
87ttqtehe5.fsf@gnu.org
Hey,

Toggle quote (2 lines)
> +(define-public libmseed

https://qa.guix.gnu.org/issue/65099reports that this package is not
building on armhf-linux and i686-linux. Do you think it could be easily
fixed?

Thanks,

Mathieu
V
V
Vinicius Monego wrote on 7 Apr 21:51 +0200
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 65099-done@debbugs.gnu.org)
213d86be7f45332c95f14984ac9c64c9a2a50b91.camel@posteo.net
Em sáb, 2023-10-14 às 10:29 +0200, Mathieu Othacehe escreveu:
Toggle quote (15 lines)
>
> Hey,
>
> > +(define-public libmseed
>
> https://qa.guix.gnu.org/issue/65099 reports that this package is not
> building on armhf-linux and i686-linux. Do you think it could be
> easily
> fixed?
>
> Thanks,
>
> Mathieu
>

Hello,

I pushed the patch with a version update. Unfortunately, I don't know
how to fix the build on other ISAs, or if version 3+ even supports 32
bit ones.

Vinicius
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65099@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65099
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch