(address . guix-patches@gnu.org)
Hi!
Note that this patch suffers for some problems:
- the package will skips the test (it complains "tk" can not be found");
- the manpages will not be installed as make installs exit with an error code because the script 'dtplite' can not be found (seems a TCL script according to README);
- the license seems X11 to me, but i am unsure (see the last paragraph in the file: "license.terms".
Any suggestion to improve the patch is appreciated! :)
Bye!
C.
---
gnu/packages/tcl.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index b69dba2254..5bfcc63f96 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -509,3 +509,43 @@ (define-public go-github.com-nsf-gothic
(description "Gothic contains Go bindings for Tcl/Tk. The package contains
only one type and one function that can be used to create a Tk interpreter.")
(license license:expat))))
+
+
+
+(define-public tk-img
+ (package
+ (name "tk-img")
+ (version "1.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/tkimg/tkimg/1.4/tkimg%20"
+ version
+ "/Img-" version "-Source.tar.gz"))
+ (file-name (string-append "tkimg-" version ".tar.gz"))
+ (sha256
+ (base32 "08dvb8bfkxr919wp6fq14cfb9lz1v59jx1la4a6j4ks636wb243m"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "install-libraries"))))
+ #:configure-flags
+ #~(list
+ (string-append "--exec-prefix=" #$output)
+ (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl") "/lib")
+ (string-append "--with-tk="
+ (assoc-ref %build-inputs "tk") "/lib"))))
+ (native-inputs
+ (list tcl
+ tk))
+ (home-page "https://sourceforge.net/projects/tkimg/")
+ (synopsis "The Img package adds several image formats to Tcl/Tk.")
+ (description
+ "The Img package adds several image formats to Tcl/Tk.")
+ (license license:public-domain)))
base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b
--
2.34.0