[PATCH 0/2] Update syncthing

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 5 Aug 2023 10:17
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
cover.1691223319.git.timotej.lazar@araneo.si
Hi,

this updates syncthing to latest version and switches to new package
style. I was able to build and run the sole dependent syncthing-gtk.

Thanks!

Timotej Lazar (2):
gnu: syncthing: Update to 1.23.6.
gnu: syncthing: Use new package style.

gnu/packages/syncthing.scm | 113 +++++++++++++++++--------------------
1 file changed, 51 insertions(+), 62 deletions(-)


base-commit: 17fadbb5ea3b35f962ab1bcd5b8cf4e1d699eb7e
--
2.41.0
T
T
Timotej Lazar wrote on 5 Aug 2023 10:20
[PATCH 1/2] gnu: syncthing: Update to 1.23.6.
(address . 65066@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
ff279bd7442086f91d26bb00137feafba294ce5e.1691223319.git.timotej.lazar@araneo.si
* gnu/packages/syncthing.scm (syncthing): Update to 1.23.6.
---
gnu/packages/syncthing.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index dd54100ce6..6ae8016491 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,7 +46,7 @@ (define-module (gnu packages syncthing)
(define-public syncthing
(package
(name "syncthing")
- (version "1.23.4")
+ (version "1.23.6")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -54,7 +54,7 @@ (define-public syncthing
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "1yi9adlp30myizlmv7a118cwrm6w1qfv09b0z7x1b7n4i8pqi8h6"))))
+ "03myinspq61aiis29mq0xjigj5rh5jd8m0d9xakf43vi7pqgwjbc"))))
(build-system go-build-system)
;; The primary Syncthing executable goes to "out", while the auxiliary
;; server programs and utility tools go to "utils". This reduces the size
--
2.41.0
T
T
Timotej Lazar wrote on 5 Aug 2023 10:20
[PATCH 2/2] gnu: syncthing: Use new package style.
(address . 65066@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
bdc5464b395847c58dcfdb365b3c93439f24a645.1691223319.git.timotej.lazar@araneo.si
* gnu/packages/syncthing.scm (syncthing)[arguments]: Use gexps. Drop trailing
---
gnu/packages/syncthing.scm | 109 +++++++++++++++++--------------------
1 file changed, 49 insertions(+), 60 deletions(-)

Toggle diff (132 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6ae8016491..414395251b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -61,76 +61,65 @@ (define-public syncthing
;; of "out" by ~144 MiB.
(outputs '("out" "utils"))
(arguments
- `(#:modules ((srfi srfi-26) ; for cut
- (guix build utils)
- (guix build go-build-system))
- #:go ,go-1.19
- #:import-path "github.com/syncthing/syncthing"
- ;; We don't need to install the source code for end-user applications.
- #:install-source? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'increase-test-timeout
- (lambda _
- (substitute* "src/github.com/syncthing/syncthing/build.go"
- (("120s") "999s"))
- #t))
+ (list #:modules '((srfi srfi-26) ; for cut
+ (guix build utils)
+ (guix build go-build-system))
+ #:go go-1.19
+ #:import-path "github.com/syncthing/syncthing"
+ ;; We don't need to install the source code for end-user applications.
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'increase-test-timeout
+ (lambda _
+ (substitute* "src/github.com/syncthing/syncthing/build.go"
+ (("120s") "999s"))))
- (replace 'build
- (lambda _
- (with-directory-excursion "src/github.com/syncthing/syncthing"
- ;; XXX The only way to build Syncthing without its automatic
- ;; updater and to build the utilities is to "build all" and then
- ;; "build syncthing" again with -no-upgrade.
- ;; https://github.com/syncthing/syncthing/issues/6118
- (invoke "go" "run" "build.go")
- (delete-file "bin/syncthing")
- (invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
+ (replace 'build
+ (lambda _
+ (with-directory-excursion "src/github.com/syncthing/syncthing"
+ ;; XXX The only way to build Syncthing without its automatic
+ ;; updater and to build the utilities is to "build all" and then
+ ;; "build syncthing" again with -no-upgrade.
+ ;; https://github.com/syncthing/syncthing/issues/6118
+ (invoke "go" "run" "build.go")
+ (delete-file "bin/syncthing")
+ (invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "src/github.com/syncthing/syncthing"
- (invoke "go" "run" "build.go" "test")))
- #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "src/github.com/syncthing/syncthing"
+ (invoke "go" "run" "build.go" "test")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (utils (assoc-ref outputs "utils")))
- (with-directory-excursion "src/github.com/syncthing/syncthing/bin"
- (install-file "../syncthing" (string-append out "/bin"))
- (for-each (cut install-file <> (string-append utils "/bin/"))
- '("stcompdirs" "stcrashreceiver"
- "stdisco" "stdiscosrv" "stevents" "stfileinfo"
- "stfinddevice" "stfindignored" "stgenfiles"
- "strelaypoolsrv" "strelaysrv" "stsigtool"
- "stvanity" "stwatchfile" "uraggregate" "ursrv"))
- #t))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "src/github.com/syncthing/syncthing/bin"
+ (install-file "../syncthing" (string-append #$output "/bin"))
+ (for-each (cut install-file <> (string-append #$output:utils "/bin/"))
+ '("stcompdirs" "stcrashreceiver"
+ "stdisco" "stdiscosrv" "stevents" "stfileinfo"
+ "stfinddevice" "stfindignored" "stgenfiles"
+ "strelaypoolsrv" "strelaysrv" "stsigtool"
+ "stvanity" "stwatchfile" "uraggregate" "ursrv")))))
(add-after 'install 'install-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (utils (assoc-ref outputs "utils"))
- (man "/share/man")
- (man-section (string-append man "/man"))
- (src "src/github.com/syncthing/syncthing/man/"))
+ (lambda _
+ (let ((man (string-append #$output "/share/man"))
+ (man:utils (string-append #$output:utils "/share/man")))
;; Install all the man pages to "out".
(for-each
- (lambda (file)
- (install-file file
- (string-append out man-section
- (string-take-right file 1))))
- (find-files src "\\.[1-9]"))
+ (lambda (file)
+ (install-file file
+ (string-append man "/man" (string-take-right file 1))))
+ (find-files "src/github.com/syncthing/syncthing/man" "\\.[1-9]"))
;; Copy all the man pages to "utils"
- (copy-recursively (string-append out man)
- (string-append utils man))
+ (copy-recursively man man:utils)
;; Delete extraneous man pages from "out" and "utils",
;; respectively.
- (delete-file (string-append out man "/man1/stdiscosrv.1"))
- (delete-file (string-append out man "/man1/strelaysrv.1"))
- (delete-file (string-append utils man "/man1/syncthing.1"))
- #t))))))
+ (delete-file (string-append man "/man1/stdiscosrv.1"))
+ (delete-file (string-append man "/man1/strelaysrv.1"))
+ (delete-file (string-append man:utils "/man1/syncthing.1"))))))))
(synopsis "Decentralized continuous file system synchronization")
(description "Syncthing is a peer-to-peer file synchronization tool that
supports a wide variety of computing platforms. It uses the Block Exchange
--
2.41.0
L
L
Ludovic Courtès wrote on 21 Aug 2023 23:17
Re: bug#65066: [PATCH 0/2] Update syncthing
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 65066-done@debbugs.gnu.org)
87y1i46qp9.fsf@gnu.org
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

Toggle quote (3 lines)
> gnu: syncthing: Update to 1.23.6.
> gnu: syncthing: Use new package style.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65066@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65066
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch