[PATCH] gnu: alacritty: Install example configuration.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 3 Aug 2023 22:07
(name . Guix-patches)(address . guix-patches@gnu.org)
87fs4zriu3.fsf@protonmail.com
Hi guix,

A quick simple patch to include alacritty's example configuration file as part of docs (I followed e.g. Arch's packaging putting it there rather than e.g. /etc). I wasn't sure the style of copy-file vs install-file and this custom install phase so went with what seemed cleanest. Tested it builds locally.

John
From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
From: John Kehayias <john.kehayias@protonmail.com>
Date: Thu, 3 Aug 2023 15:54:52 -0400
Subject: [PATCH] gnu: alacritty: Install example configuration.
* gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
configuration.
---
gnu/packages/terminals.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 081ef19af1..d54910bce7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1515,6 +1515,9 @@ (define-public alacritty
(mkdir-p man)
(copy-file "extra/alacritty.man"
(string-append man "/alacritty.1"))
+ ;; Install example configuration.
+ (install-file "alacritty.yml"
+ (string-append share "/doc/alacritty-" ,version "/example"))
;; Install desktop file.
(install-file "extra/linux/Alacritty.desktop"
(string-append share "/applications"))
base-commit: 4ded034a57ffacdd6c7afa73bb58893afd614644
--
2.41.0
L
L
Ludovic Courtès wrote on 17 Aug 2023 17:51
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 65044@debbugs.gnu.org)
87v8ddvf9k.fsf@gnu.org
Hi,

John Kehayias <john.kehayias@protonmail.com> skribis:

Toggle quote (24 lines)
> From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
> Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
> From: John Kehayias <john.kehayias@protonmail.com>
> Date: Thu, 3 Aug 2023 15:54:52 -0400
> Subject: [PATCH] gnu: alacritty: Install example configuration.
>
> * gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
> configuration.
> ---
> gnu/packages/terminals.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
> index 081ef19af1..d54910bce7 100644
> --- a/gnu/packages/terminals.scm
> +++ b/gnu/packages/terminals.scm
> @@ -1515,6 +1515,9 @@ (define-public alacritty
> (mkdir-p man)
> (copy-file "extra/alacritty.man"
> (string-append man "/alacritty.1"))
> + ;; Install example configuration.
> + (install-file "alacritty.yml"
> + (string-append share "/doc/alacritty-" ,version "/example"))

Nitpick: ,(package-version this-package)

That means it will pick the right version string when inheriting, as in:

(package
(inherit alacritty)
(version "42.0")
…)

Otherwise LGTM, thanks!

Ludo’.
J
J
John Kehayias wrote on 18 Aug 2023 17:50
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 65044-done@debbugs.gnu.org)
87y1i8pcxm.fsf@protonmail.com
Hello,

On Thu, Aug 17, 2023 at 05:51 PM, Ludovic Courtès wrote:

Toggle quote (38 lines)
> Hi,
>
> John Kehayias <john.kehayias@protonmail.com> skribis:
>
>> From 08831e7530a1c5ef6b87e293051c4b92f10d1513 Mon Sep 17 00:00:00 2001
>> Message-ID: <08831e7530a1c5ef6b87e293051c4b92f10d1513.1691093041.git.john.kehayias@protonmail.com>
>> From: John Kehayias <john.kehayias@protonmail.com>
>> Date: Thu, 3 Aug 2023 15:54:52 -0400
>> Subject: [PATCH] gnu: alacritty: Install example configuration.
>>
>> * gnu/packages/terminals.scm (alacritty)[phases]{install}: Install example
>> configuration.
>> ---
>> gnu/packages/terminals.scm | 3 +++
>> 1 file changed, 3 insertions(+)
>>
>> diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
>> index 081ef19af1..d54910bce7 100644
>> --- a/gnu/packages/terminals.scm
>> +++ b/gnu/packages/terminals.scm
>> @@ -1515,6 +1515,9 @@ (define-public alacritty
>> (mkdir-p man)
>> (copy-file "extra/alacritty.man"
>> (string-append man "/alacritty.1"))
>> + ;; Install example configuration.
>> + (install-file "alacritty.yml"
>> + (string-append share "/doc/alacritty-" ,version "/example"))
>
> Nitpick: ,(package-version this-package)
>
> That means it will pick the right version string when inheriting, as in:
>
> (package
> (inherit alacritty)
> (version "42.0")
> …)
>

Good point, thanks.

Toggle quote (3 lines)
> Otherwise LGTM, thanks!
>

Made the change and pushed as d1c811268d130041b5af1ba8f8b41cdafe8f08b5 (and followed up with another commit to update source and home-page URLs as guix lint noted a redirect.)

John
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65044@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65044
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch