[PATCH] gnu: python-graph-tool: Update to 2.57.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Christopher Baines
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 3 Aug 2023 19:59
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230803180002.22937-1-code@greghogan.com
* gnu/packages/graph.scm (python-graph-tool): Update to 2.57.
[propagated-inputs]: Add python-zstandard.
---
gnu/packages/graph.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index c5e7410b2a..881033047d 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -57,6 +57,7 @@ (define-module (gnu packages graph)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -630,7 +631,7 @@ (define-public mscgen
(define-public python-graph-tool
(package
(name "python-graph-tool")
- (version "2.46")
+ (version "2.57")
(source (origin
(method url-fetch)
(uri (string-append
@@ -638,7 +639,7 @@ (define-public python-graph-tool
version ".tar.bz2"))
(sha256
(base32
- "0x9jgnq9xcja3q954y7nhdzd374p4h203pymxh51b6lqqbq0hm9h"))))
+ "0wmvzx509lvigja6cfxh45r4b7wns64vmik0x4rz4y4fnxrhw2m2"))))
(build-system gnu-build-system)
(arguments
`(#:imported-modules (,@%gnu-build-system-modules
@@ -662,7 +663,11 @@ (define-public python-graph-tool
python-wrapper
sparsehash))
(propagated-inputs
- (list python-matplotlib python-numpy python-pycairo python-scipy))
+ (list python-matplotlib
+ python-numpy
+ python-pycairo
+ python-scipy
+ python-zstandard))
(synopsis "Manipulate and analyze graphs with Python efficiently")
(description "Graph-tool is an efficient Python module for manipulation
and statistical analysis of graphs (a.k.a. networks). Contrary to most other
--
2.41.0
C
C
Christopher Baines wrote on 27 Aug 2023 20:51
(name . Greg Hogan)(address . code@greghogan.com)(address . 65043-done@debbugs.gnu.org)
878r9wz5ba.fsf@cbaines.net
Greg Hogan <code@greghogan.com> writes:

Toggle quote (6 lines)
> * gnu/packages/graph.scm (python-graph-tool): Update to 2.57.
> [propagated-inputs]: Add python-zstandard.
> ---
> gnu/packages/graph.scm | 11 ++++++++---
> 1 file changed, 8 insertions(+), 3 deletions(-)

Thanks, I've pushed this to master as
6482f61a0cf65bd32be0a9bbd0ce5c349b28c0c0.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTrm1lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xekaw/5AfF8Jqx52yy4JMLh9PMWquiVcKK1+EYl
H/SHyjzRt6hdzBW8Xj8/zcWZBwztIIy4rmsnUi2pTEnpYEF1wAjfGdKxdE0dDsGP
uinApk3Ov6l6RdqQMaJ7PplroqEJ7uxLzTvM1ahlFrqg1EJNizO9FM1q9HP83Szc
APkK4D82nwKsZoWq3F1jFRw5h1/orVuP2o9W8d0H7TAeVkgFAQqA3agcg+dLtWNu
vVjEin+csoFOWUntrro32NreuwWV0lAYhO1pSq08J3JRlsrLF8vtrDvXxDNbuQG1
uhH5xxnLB48KRA+s6hXyYAedxRfr7F77hmrXp3uzlwVVUvaNOivqlso2yGZQUOGD
ZnlgSP+kBeo3ozYN33V7QoBiJb9JIWSjHdUv14cdnVYucJxJgtAE/IuQ4GG69UOc
ERiIDyf29G5NvCBKvqW8Eug8kIDwJRnU8lK9aIprZ1aa7BBLIr1KF4CjMEOPB+Qu
ARMEa8LzGiyBbL07FScDuT46i6O4GPEXsXR3WY9cJiQUKU02QxQuKpjqN/tpbtds
v3I0ay5dBVWwse1oEg77JM+aWAKyHK4mjkV5oAfAfkb9vyXjLHwfDLg3qIskx7ei
z8Ez8i5vmLaZcK7es7eIqOZxUriAtH223dEdLfWt6kBo7EONWUnriAeouWl8UY+P
IdbX+o+nhoQ=
=hd8D
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65043@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65043
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch