[PATCH] gnu: Add python-baltica.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
4cf18f120f7829851d9bc97ce7210b04fde22f72.1690897596.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-baltica): New variable.
---
gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6080c899af..6d745262b3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5056,6 +5056,49 @@ (define-public edirect-go-programs
go-golang-org-x-image
go-golang-org-x-text))))
+(define-public python-baltica
+ (package
+ (name "python-baltica")
+ (version "1.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dieterich-lab/Baltica")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "001ac03v9pbqqzf9pv7v8gf0296ksa4f0v3wdmpa6m9701skqi4r"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases '(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; The tests need to be run from elsewhere...
+ (mkdir-p "/tmp/test")
+ (copy-recursively ".tests" "/tmp/test")
+ (with-directory-excursion "/tmp/test"
+ (invoke "pytest" "-v" "--doctest-modules")))))))
+ (propagated-inputs (list python-anndata
+ python-click
+ python-flask
+ python-flask-wtf
+ gunicorn
+ python-h5py
+ python-pysam
+ python-numpy
+ python-psutil
+ python-pyyaml
+ python-scipy
+ snakemake-7))
+ (native-inputs (list python-pytest python-pyfakefs python-cython))
+ (home-page "https://github.com/dieterich-lab/Baltica")
+ (synopsis "Integrated splice junction usage analysis")
+ (description
+ "This framework facilitates the execution of differential junction usage methods.
+Additionally, it enables the integration of results from multiple DJU methods.")
+ (license license:expat)))
+
(define-public python-bamnostic
(package
(name "python-bamnostic")

base-commit: 34b56974dfe720e5e30f04409ac216747d7e3f5c
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 64992-done@debbugs.gnu.org)
87a5va7xcu.fsf@elephly.net
Pushed with commit 5a293d0830aa9369e388d37fe767d5bf98af01b7. Thanks for
the patch!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64992@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64992
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help