(address . bug-guix@gnu.org)
Hello,
When running "guix build -f alps.scm" where alps.scm uses url-fetch with
(uri
the following error occurs
guix build: error: invalid character `~' in name
'alps_20220304~r7871.orig.tar.gz.drv'
Bug was noted at
repository URL: https://git.savannah.gnu.org/git/guix.git
commit: c173819c8e5235ce02d60b79bd88b10023a7c614
branch: master
(define-module (alps)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
;; #:use-module (gnu packages cmake)
#:use-module ((guix licenses)
#:prefix license:)
#:use-module (guix build utils)
#:use-module (guix gexp)
#:use-module (gnu packages boost)
#:use-module (gnu packages algebra)
#:use-module (gnu packages maths)
)
(define-public alps
(package
(name "alps")
(version "7871")
(source (origin
(method url-fetch)
(uri
(string-append
"https://exa.phys.s.u-tokyo.ac.jp/archive/"
"MateriApps/src/alps_20220304~r7871.orig.tar.gz"))
(sha256
(base32
"09klx0samxz9lap2j9q19264bdpydbrfqq1wmwwi9y01cwavkg3l"))))
(build-system cmake-build-system)
(arguments
(list
#:tests? #t
#:configure-flags #~(list "-DALPS_BUILD_PYTHON=OFF")))
(native-inputs (list))
(inputs
(list boost fftw openblas hdf5))
(propagated-inputs (list))
(synopsis "Algorithms and Libraries for Physics Simulations")
(description
"The ALPS project (Algorithms and Libraries for Physics
Simulations) is an open source effort aiming at providing high-end
simulation codes for strongly correlated quantum mechanical systems as
well as C++ libraries for simplifying the development of such
code. ALPS strives to increase software reuse in the physics
community.")
(home-page (string-append
"https://web.archive.org/web/20210508050408/"
"https://alps.comp-phys.org/mediawiki/index.php/Main_Page"))
(license (license:non-copyleft "file://LICENSE"
"See README in the deistribution."))))
alps