(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
* gnu/packages/fontutils.scm (python-fontmake): New variable.
---
gnu/packages/fontutils.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 153602b4b4..a9dafcba2b 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -510,6 +510,31 @@ (define-public python-ufo2ft
to generate OpenType font binaries from Unified Font Objects (UFOs).")
(license license:expat)))
+(define-public python-fontmake
+ (package
+ (name "python-fontmake")
+ (version "3.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "fontmake" version ".zip"))
+ (sha256
+ (base32
+ "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-attrs
+ python-fontmath
+ python-fonttools-minimal
+ python-glyphslib
+ python-ufo2ft
+ python-ufolib2))
+ (native-inputs (list unzip python-setuptools-scm))
+ (home-page "https://github.com/googlei18n/fontmake")
+ (synopsis
+ "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
+ (description
+ "Fontmake compiles fonts from various sources (.glyphs, .ufo, designspace) into binaries (.otf, .ttf). You can use it to create static instances and variable fonts.")
+ (license license:asl2.0)))
+
(define-public python-fontmath
(package
(name "python-fontmath")
base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
prerequisite-patch-id: 92a3fab6e4174a4d4877fc5b426752df81e4df39
prerequisite-patch-id: ebf3fd3a8bb02f7dc5cdf504f63d5028b29fe69e
--
2.39.2