[PATCH] gnu: Add font-open-fonts.

  • Open
  • quality assurance status badge
Details
One participant
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
S
S
Sergio Pastor Pérez wrote on 30 Jul 2023 16:47
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132D4E70F9F298148610C5AF304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/fonts.scm (font-open-fonts): New variable.
---
gnu/packages/fonts.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index d5fed4911f..3924bbc82d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3437,3 +3437,23 @@ (define-public font-pragmasevka
(synopsis "Iosevka font variant that mimics PragmataPro")
(description "Pragmata Pro doppelgänger made of Iosevka SS08.")
(license license:silofl1.1)))
+
+(define-public font-open-fonts
+ (package
+ (name "font-open-fonts")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/kiwi0fruit/open-fonts/releases/download/" version "/open-fonts.tar.xz"))
+ (file-name (string-append name version ".tar.gz"))
+ (sha256
+ (base32
+ "1z48g87gil0nv105ci5iimz3zdgfrn62bh38xr33yrz0pdv9p4il"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/kiwi0fruit/open-fonts/")
+ (synopsis
+ "A collection of beautiful free and open source fonts")
+ (description
+ "This package provides open source fonts with a variety of styles which include Sans Serif, Serif and Monospeced fonts.")
+ (license license:expat)))

base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
--
2.39.2
S
S
Sergio Pastor Pérez wrote on 30 Jul 2023 16:57
[PATCH vREVISION] gnu: Add font-open-fonts.
(address . 64955@debbugs.gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB21328989DA12172A5DBAC2C4F304A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/fonts.scm (font-open-fonts): New variable.
---
Fix formating with `guix style`

gnu/packages/fonts.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index d5fed4911f..25659ab8d6 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3437,3 +3437,23 @@ (define-public font-pragmasevka
(synopsis "Iosevka font variant that mimics PragmataPro")
(description "Pragmata Pro doppelgänger made of Iosevka SS08.")
(license license:silofl1.1)))
+
+(define-public font-open-fonts
+ (package
+ (name "font-open-fonts")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/kiwi0fruit/open-fonts/releases/download/"
+ version "/open-fonts.tar.xz"))
+ (file-name (string-append name version ".tar.gz"))
+ (sha256
+ (base32
+ "1z48g87gil0nv105ci5iimz3zdgfrn62bh38xr33yrz0pdv9p4il"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/kiwi0fruit/open-fonts/")
+ (synopsis "A collection of beautiful free and open source fonts")
+ (description
+ "This package provides open source fonts with a variety of styles which include Sans Serif, Serif and Monospeced fonts.")
+ (license license:expat)))

base-commit: c173819c8e5235ce02d60b79bd88b10023a7c614
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
prerequisite-patch-id: 3e6318d61f2efa01f4435152f2139eef8f72572c
prerequisite-patch-id: 1b23c59bab92820a1e102137909922f4d71ed8f9
prerequisite-patch-id: 78a291411f8d86beabbf6d49df0cc78702ad4e65
prerequisite-patch-id: 579224b39cae7869ce11e2e8dba046b5eef606c7
prerequisite-patch-id: f1f62fd5d83d603ca35c17071e615352e90753e3
prerequisite-patch-id: 1843bca37f83e494be67c24e975727fb1fe1248c
prerequisite-patch-id: 5cc0d6cd16ae2ab21c444ed9cabfeea5615e8cda
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64955@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64955
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch