(address . bug-guix@gnu.org)
Hey guix,
Anthy has been giving me grief lately. It's not showing up in ibus-setup's list
of input methods.
After futzing around with ibus and gsettings for a while, I noticed this:
$ guix shell --pure ibus ibus-anthy
$ ibus read-cache | xml sel -t -c '(//name[text()="org.freedesktop.IBus.Anthy"])[1]/..' -n
<component>
<name>org.freedesktop.IBus.Anthy</name>
<description>Anthy Component</description>
<version>1.5.14</version>
<license>GPL</license>
<author>Peng Huang <shawn.p.huang@gmail.com></author>
<homepage>https://github.com/ibus/ibus/wiki/homepage
<exec>/gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/libexec/ibus-engine-anthy --ibus</exec>
<textdomain>ibus-anthy</textdomain>
<observed-paths>
<path mtime="1">/home/x/.guix-profile/share/ibus/component/anthy.xml</path>
<path mtime="0">~/.config/ibus-anthy/engines.xml</path>
<path mtime="1">/gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/share/ibus-anthy/engine/default.xml</path>
</observed-paths>
<engines>
</engines>
</component>
So anthy is definitely detected by ibus, but directly running that exec command
results in Python falling over:
$ /gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/libexec/ibus-engine-anthy --ibus
Traceback (most recent call last):
File "/gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/share/ibus-anthy/engine/main.py", line 44, in <module>
import factory
File "/gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/share/ibus-anthy/engine/factory.py", line 33, in <module>
import engine
File "/gnu/store/bm3jm0d942ljzmbckbg4872cj70ljqzi-ibus-anthy-1.5.14/share/ibus-anthy/engine/engine.py", line 59, in <module>
from anthyprefs import AnthyPrefs
ModuleNotFoundError: No module named 'anthyprefs'
Any idea on what might be going on? I have had this issue for about a month,
but the above was performed with
$ guix describe
Generation 16 Jul 30 2023 09:58:49 (current)
guix 6b903e2
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 6b903e210462f7c1e428e0ded7e690d315e1f7a1
...