[PATCH] gnu: Add termdown

  • Open
  • quality assurance status badge
Details
One participant
  • Abhiseck Paira
Owner
unassigned
Submitted by
Abhiseck Paira
Severity
normal
A
A
Abhiseck Paira wrote on 29 Jul 2023 23:45
(address . guix-patches@gnu.org)
68d606b92416b5501da866d5840112be5eae2169.1690667339.git.abhiseckpaira@disroot.org
* gnu/packages/time.scm (termdown): New variable.
---
gnu/packages/time.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 5c8f65a1e6..6d0c4c5aa1 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -606,6 +606,31 @@ (define-public tz
TUI program that displays time across a few time zones of your choosing.")
(license gpl3+)))
+(define-public termdown
+ (package
+ (name "termdown")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "termdown" version))
+ (sha256
+ (base32
+ "07nxsqpwnpr9jkvif2ngjlcq05z0ldnmqxd15d1l593lzmxdyrci"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-click
+ python-pyfiglet
+ python-dateutil))
+ (home-page "https://github.com/trehn/termdown")
+ (synopsis "Countdown timer for your terminal")
+ (description
+ "Termdown provides a fancy text display while it counts down to zero from
+a starting point you provide. The user can pause and resume the countdown
+from the text user interface. It can also be used in stop watch mode which
+counts forward or for just showing the current time.")
+ (license gpl3)))
+
(define-public countdown
(package
(name "countdown")

base-commit: ecdcafc007e3a06647e02e2077e0ff352b38c06f
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64940@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64940
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch