[PATCH] gnu: Add abstract-sddm-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
S
S
Sergio Pastor Pérez wrote on 29 Jul 2023 14:50
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB213205400BEA682070A3880CF307A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/display-managers.scm (abstract-sddm-theme): New variable.
---
gnu/packages/display-managers.scm | 33 +++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index dcfa3bcf3f..f33889d23d 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -177,6 +177,39 @@ (define-public dexy-color-sddm-theme
(description "Dexy-Color-SDDM is part of KDE Themes and Extensions.")
(license license:gpl3+))))
+(define-public abstract-sddm-theme
+ (let ((commit "e817d4b27981080cd3b398fe928619ffa16c52e7")
+ (revision "0"))
+ (package
+ (name "abstract-sddm-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/3ximus/abstractdark-sddm-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (sddm-themes (string-append out
+ "/share/sddm/themes")))
+ (mkdir-p sddm-themes)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ (string-append sddm-themes
+ "/abstract"))))))
+ (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
+ (synopsis "Abstract Dark theme for SDDM")
+ (description
+ "This package provides a simple theme for SDDM inspired by solarized-sddm-theme.")
+ (license license:gpl3+))))
+
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")

base-commit: e43cbeafd1b632f39b08b3644af5230d5350a656
prerequisite-patch-id: c56db9fa7fc4e07452dea53f2d450bd83abbbc1a
--
2.39.2
L
L
Ludovic Courtès wrote on 17 Sep 2023 15:15
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)(address . 64932@debbugs.gnu.org)
87a5tlx7nr.fsf@gnu.org
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

Toggle quote (2 lines)
> * gnu/packages/display-managers.scm (abstract-sddm-theme): New variable.

[...]

Toggle quote (17 lines)
> + (build-system trivial-build-system)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder (begin
> + (use-modules (guix build utils))
> + (let* ((out (assoc-ref %outputs "out"))
> + (sddm-themes (string-append out
> + "/share/sddm/themes")))
> + (mkdir-p sddm-themes)
> + (copy-recursively (assoc-ref %build-inputs "source")
> + (string-append sddm-themes
> + "/abstract"))))))
> + (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
> + (synopsis "Abstract Dark theme for SDDM")
> + (description
> + "This package provides a simple theme for SDDM inspired by solarized-sddm-theme.")

Same suggestions as for dexy-color-sddm-theme. :-)

Ludo’.
S
S
Sergio Pastor Pérez wrote on 20 Sep 2023 23:30
[PATCH v2] gnu: Add abstractdark-sddm-theme.
(address . ludo@gnu.org)
DU2P193MB2132BB998401BE3CDED510C0F3F9A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/display-managers.scm (abstractdark-sddm-theme): New variable.
---
Hi.

Here you have the corrections you've asked. I've sent you another mail with the
changes for the dexy-color-sddm-theme.

Good night,
Sergio.

gnu/packages/display-managers.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index ef9826c0f7..ba9e26142e 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -168,6 +168,31 @@ (define-public dexy-color-sddm-theme
background.")
(license license:gpl3+))))
+(define-public abstractdark-sddm-theme
+ (let ((commit "e817d4b27981080cd3b398fe928619ffa16c52e7")
+ (revision "0"))
+ (package
+ (name "abstractdark-sddm-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/3ximus/abstractdark-sddm-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("." "/share/sddm/themes/abstractdark"))))
+ (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
+ (synopsis "Abstract Dark theme for SDDM")
+ (description
+ "This package provides a minimalistic dark theme for SDDM, black
+background with abstract shapes. Inspired by solarized-sddm-theme.")
+ (license license:gpl3+))))
+
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")

base-commit: 4bdb8bd2674c2b630626be43a5cd3c2b65401b52
prerequisite-patch-id: 5c871c0f03698adb5cbf1aa075bfce296029bc03
--
2.41.0
L
L
Ludovic Courtès wrote on 14 Oct 2023 17:30
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)(address . 64932-done@debbugs.gnu.org)
87ttqtfchq.fsf@gnu.org
HI,

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> skribis:

Toggle quote (7 lines)
> * gnu/packages/display-managers.scm (abstractdark-sddm-theme): New variable.
> ---
> Hi.
>
> Here you have the corrections you've asked. I've sent you another mail with the
> changes for the dexy-color-sddm-theme.

I had to add #:use-module (guix build-system copy). Applied with this
change.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch