'guix shell -D po4a' fails (texlive-font-maps.drv build failure)

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 27 Jul 2023 22:51
(name . bug-guix)(address . bug-guix@gnu.org)
87ila5xel1.fsf@gmail.com
Hi,

While attempting to hack on po4a I've found 'guix shell -D po4a' would
fail like so:

Toggle snippet (42 lines)
Transcript written on: {/tmp/texlive/share/texmf-dist}/../texmf-var/web2c/updmap.log
updmap: updating ls-R files.
`/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz9-texlive-font-maps/share/texmf-dist/fonts/map/dvipdfmx/updmap/kanjix.map' -> `/tmp/texlive/share/texmf-dist/fonts/map/dvipdfmx/updmap/kanjix.map'
Backtrace:
16 (primitive-load "/gnu/store/b76nnrqi8g418ibr8i2h113wz2z?")
In ice-9/eval.scm:
619:8 15 (_ #(#(#(#(#<directory (guile-user) 7ffff77?> ?) ?) ?) ?))
In ice-9/ftw.scm:
475:33 14 (loop _ _ #(25 307354922 16877 1 999 30000 0 20 # # # ?) ?)
In srfi/srfi-1.scm:
460:18 13 (fold #<procedure 7ffff50b7660 at ice-9/ftw.scm:475:38?> ?)
In unknown file:
12 (_ #<procedure 7ffff4b98990 at ice-9/ftw.scm:477:44 ()> ?)
In ice-9/ftw.scm:
475:33 11 (loop _ _ #(25 307354925 16877 1 999 30000 0 6 # # # ?) ?)
In srfi/srfi-1.scm:
460:18 10 (fold #<procedure 7ffff50b72a0 at ice-9/ftw.scm:475:38?> ?)
In unknown file:
9 (_ #<procedure 7ffff4b98510 at ice-9/ftw.scm:477:44 ()> ?)
In ice-9/ftw.scm:
475:33 8 (loop _ _ #(25 307354926 16877 1 999 30000 0 38 # # # ?) ?)
In srfi/srfi-1.scm:
460:18 7 (fold #<procedure 7ffff50cfdc0 at ice-9/ftw.scm:475:38?> ?)
In unknown file:
6 (_ #<procedure 7ffff4b5cf00 at ice-9/ftw.scm:477:44 ()> ?)
In ice-9/ftw.scm:
475:33 5 (loop _ _ #(25 307354931 16877 1 999 30000 0 12 # # # ?) ?)
In srfi/srfi-1.scm:
460:18 4 (fold #<procedure 7ffff50cf9a0 at ice-9/ftw.scm:475:38?> ?)
In unknown file:
3 (_ #<procedure 7ffff4b5c900 at ice-9/ftw.scm:477:44 ()> ?)
In ice-9/ftw.scm:
505:39 2 (loop _ _ #(25 307354932 16877 1 999 30000 0 20 # # # ?) ?)
In guix/build/utils.scm:
454:27 1 (_ "/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz9-texliv?" ?)
In unknown file:
0 (copy-file "/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz?" ?)

ERROR: In procedure copy-file:
In procedure copy-file: Permission denied

I'm not sure if or how this problem is related to the other TexLive
issues recently discovered.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 27 Jul 2023 23:11
Re: bug#64906: Acknowledgement ('guix shell -D po4a' fails (texlive-font-maps.drv build failure))
(address . 64906@debbugs.gnu.org)
87edktxdp7.fsf@gmail.com
Hi,

I've isolated the part that fails to the second 'updmap-sys' invocation
in the 'texlive-font-maps' profile hook; the following allowed 'guix -D
po4a texlive-bin' to succeed without errors:

Toggle snippet (26 lines)
modified guix/profiles.scm
@@ -1847,14 +1847,14 @@ (define (texlive-font-maps manifest)
(error "failed to filter updmap.cfg")))
;; Generate font maps.
- (invoke #$(file-append texlive-scripts "/bin/updmap-sys")
- (string-append "--cnffile=" updmap.cfg)
- (string-append "--dvipdfmxoutputdir="
- maproot "dvipdfmx/updmap")
- (string-append "--dvipsoutputdir="
- maproot "dvips/updmap")
- (string-append "--pdftexoutputdir="
- maproot "pdftex/updmap"))
+ ;; (invoke #$(file-append texlive-scripts "/bin/updmap-sys")
+ ;; (string-append "--cnffile=" updmap.cfg)
+ ;; (string-append "--dvipdfmxoutputdir="
+ ;; maproot "dvipdfmx/updmap")
+ ;; (string-append "--dvipsoutputdir="
+ ;; maproot "dvips/updmap")
+ ;; (string-append "--pdftexoutputdir="
+ ;; maproot "pdftex/updmap"))
;; Create ls-R file. I know, that's not *just* for font maps, but
;; we've generated new files, so there's no point in running it

--
Thanks,
Maxim
N
N
Nicolas Goaziou wrote on 29 Jul 2023 02:00
Re: bug#64906: 'guix shell -D po4a' fails (texlive-font-maps.drv build failure)
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 64906-done@debbugs.gnu.org)
87bkfv1t9d.fsf@nicolasgoaziou.fr
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:


Toggle quote (49 lines)
> While attempting to hack on po4a I've found 'guix shell -D po4a' would
> fail like so:
>
> --8<---------------cut here---------------start------------->8---
> Transcript written on: {/tmp/texlive/share/texmf-dist}/../texmf-var/web2c/updmap.log
> updmap: updating ls-R files.
> `/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz9-texlive-font-maps/share/texmf-dist/fonts/map/dvipdfmx/updmap/kanjix.map' -> `/tmp/texlive/share/texmf-dist/fonts/map/dvipdfmx/updmap/kanjix.map'
> Backtrace:
> 16 (primitive-load "/gnu/store/b76nnrqi8g418ibr8i2h113wz2z?")
> In ice-9/eval.scm:
> 619:8 15 (_ #(#(#(#(#<directory (guile-user) 7ffff77?> ?) ?) ?) ?))
> In ice-9/ftw.scm:
> 475:33 14 (loop _ _ #(25 307354922 16877 1 999 30000 0 20 # # # ?) ?)
> In srfi/srfi-1.scm:
> 460:18 13 (fold #<procedure 7ffff50b7660 at ice-9/ftw.scm:475:38?> ?)
> In unknown file:
> 12 (_ #<procedure 7ffff4b98990 at ice-9/ftw.scm:477:44 ()> ?)
> In ice-9/ftw.scm:
> 475:33 11 (loop _ _ #(25 307354925 16877 1 999 30000 0 6 # # # ?) ?)
> In srfi/srfi-1.scm:
> 460:18 10 (fold #<procedure 7ffff50b72a0 at ice-9/ftw.scm:475:38?> ?)
> In unknown file:
> 9 (_ #<procedure 7ffff4b98510 at ice-9/ftw.scm:477:44 ()> ?)
> In ice-9/ftw.scm:
> 475:33 8 (loop _ _ #(25 307354926 16877 1 999 30000 0 38 # # # ?) ?)
> In srfi/srfi-1.scm:
> 460:18 7 (fold #<procedure 7ffff50cfdc0 at ice-9/ftw.scm:475:38?> ?)
> In unknown file:
> 6 (_ #<procedure 7ffff4b5cf00 at ice-9/ftw.scm:477:44 ()> ?)
> In ice-9/ftw.scm:
> 475:33 5 (loop _ _ #(25 307354931 16877 1 999 30000 0 12 # # # ?) ?)
> In srfi/srfi-1.scm:
> 460:18 4 (fold #<procedure 7ffff50cf9a0 at ice-9/ftw.scm:475:38?> ?)
> In unknown file:
> 3 (_ #<procedure 7ffff4b5c900 at ice-9/ftw.scm:477:44 ()> ?)
> In ice-9/ftw.scm:
> 505:39 2 (loop _ _ #(25 307354932 16877 1 999 30000 0 20 # # # ?) ?)
> In guix/build/utils.scm:
> 454:27 1 (_ "/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz9-texliv?" ?)
> In unknown file:
> 0 (copy-file "/gnu/store/rlbyrr5rnsmfi0aani1ibkrlszp7xiz?" ?)
>
> ERROR: In procedure copy-file:
> In procedure copy-file: Permission denied
> --8<---------------cut here---------------end--------------->8---
>
> I'm not sure if or how this problem is related to the other TexLive
> issues recently discovered.

This should be fixed in commit e43cbeafd1b632f39b08b3644af5230d5350a656.

Regards,
--
Nicolas Goaziou
Closed
M
M
Maxim Cournoyer wrote on 29 Jul 2023 17:44
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 64906-done@debbugs.gnu.org)
87sf96sox1.fsf@gmail.com
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

[...]

Toggle quote (2 lines)
> This should be fixed in commit e43cbeafd1b632f39b08b3644af5230d5350a656.

Yay, thank you for the prompt resolution.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64906@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64906
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch