[PATCH 0/9] rust-emacs-org-link-parser & rust-orgize

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 27 Jul 2023 16:27
(address . guix-patches@gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
cover.1690467642.git.w@wmeyer.eu
Hi Guix,

I'd like to add two crates, rust-emacs-org-link-parser and rust-orgize,
as well as their respective dependencies, to work with org-mode syntax
in rust to crates-io.scm.

Best Regards,

Wilko Meyer

Wilko Meyer (9):
gnu: Added rust-indextree-4.
gnu: Added rust-memory-units-0.4.
gnu: Added rust-orgize-0.9.
gnu: Bumped rust-rayon{,-core}-1 minor versions.
gnu: Added rust-serde-{wasm-bindgen-0.3,indextree-0.2}.
gnu: Added rust-slugify-0.1 to crates-io.scm.
gnu: Added rust-unidecode-0.3.
gnu: Added rust-wee-alloc-0.4.
gnu: Added rust-emacs-org-link-parser-0.1.

gnu/packages/crates-io.scm | 216 ++++++++++++++++++++++++++++++++++++-
1 file changed, 212 insertions(+), 4 deletions(-)


base-commit: 76b7c50645cfba9554af9c80768765c5b714b893
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 3/9] gnu: Added rust-orgize-0.9.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
89a95122865de1077b1466db87b010ce7ea84548.1690467642.git.w@wmeyer.eu
* added rust-orgize-0.9 to crates-io.scm
---
gnu/packages/crates-io.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 95c3671133..a88797f750 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40976,6 +40976,42 @@ (define-public rust-option-set-0.1
(description "This package provides an extended version of rust bitflags.")
(license license:expat)))
+(define-public rust-orgize-0.9
+ (package
+ (name "rust-orgize")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "orgize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ynpryx33yzhfb8dsnzflzsh37p39lyfv0wgw430rh33z2l9hj8y"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bytecount" ,rust-bytecount-0.6)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-indextree" ,rust-indextree-4)
+ ("rust-jetscii" ,rust-jetscii-0.5)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-nom" ,rust-nom-7)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-wasm-bindgen" ,rust-serde-wasm-bindgen-0.3)
+ ("rust-serde-indextree" ,rust-serde-indextree-0.2)
+ ("rust-syntect" ,rust-syntect-4)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-wee-alloc" ,rust-wee-alloc-0.4))
+ #:cargo-development-inputs (("rust-pretty-assertions" ,rust-pretty-assertions-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-slugify" ,rust-slugify-0.1))))
+ (home-page "https://github.com/PoiScript/orgize")
+ (synopsis "A Rust library for parsing orgmode files.")
+ (description
+ "This package provides a Rust library for parsing orgmode files.")
+ (license license:expat)))
+
(define-public rust-orbclient-0.3
(package
(name "rust-orbclient")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 2/9] gnu: Added rust-memory-units-0.4.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
9d7f958049dcfb52d41896f2b13883bc2499defd.1690467642.git.w@wmeyer.eu
* Added rust-memory-units-0.4 to crates-io.scm
---
gnu/packages/crates-io.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 91f94af642..95c3671133 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35166,6 +35166,25 @@ (define-public rust-memmap2-0.1
(sha256
(base32 "0nmymqy9q62x577ydja0ysfyir7h5qa0n5fwcnvchfhhlsi0rdyr"))))))
+(define-public rust-memory-units-0.4
+ (package
+ (name "rust-memory-units")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "memory_units" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hyk1alsdpcw5r33c5yn7pk9h259klfxv4vhzx08y1j7l1di0ll4"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/pepyakin/memory_units")
+ (synopsis "Safe conversions between units of memory")
+ (description "Safe conversions between units of memory")
+ (license license:mpl2.0)))
+
(define-public rust-memoffset-0.7
(package
(name "rust-memoffset")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 4/9] gnu: Bumped rust-rayon{,-core}-1 minor versions.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
fd4d23610278792608a639acb312f71eec9d2e31.1690467642.git.w@wmeyer.eu
* rust-rayon-1 is now at v1.7.0
* rust-rayon-core-1 is now at v1.11.0
---
gnu/packages/crates-io.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a88797f750..091bd3c399 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49226,14 +49226,14 @@ (define-public rust-rawslice-0.1
(define-public rust-rayon-1
(package
(name "rust-rayon")
- (version "1.6.1")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "rayon" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1dsr0yyfgdsg8ggh37kq678mfa5j3js6p16ksb7knazhml9s5cvd"))))
+ (base32 "0fzh8w5ds1qjhilll4rkpd3kimw70zi5605wprxcig1pdqczab8x"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -49301,14 +49301,14 @@ (define-public rust-rawkey-0.1
(define-public rust-rayon-core-1
(package
(name "rust-rayon-core")
- (version "1.10.1")
+ (version "1.11.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "rayon-core" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1lvavqk42lmll47q008j8y6nw54f3sfvcjlbaa26iaq0bnpi1i6a"))))
+ (base32 "13dymrhhdilzpbfh3aylv6ariayqdfk614b3frvwixb6d6yrb3sb"))))
(build-system cargo-build-system)
(arguments
;; One of the tests attempts to overflow the stack, but the compiler has
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 1/9] gnu: Added rust-indextree-4.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
21caffb7a057771da7e7e37505f1b573db3e29bf.1690467642.git.w@wmeyer.eu
* added rust-indextree-4 to crates-io.scm
---
gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af77a40257..91f94af642 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29160,6 +29161,30 @@ (define-public rust-indenter-0.3
that efficiently appends and removes common indentation after every newline.")
(license (list license:expat license:asl2.0))))
+(define-public rust-indextree-4
+ (package
+ (name "rust-indextree")
+ (version "4.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "indextree" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dnysxws5kpw8c3yvnhq3r9p2kfqqrgcw29x7hrg2gn6wp812164"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-rayon" ,rust-rayon-1)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/saschagrunert/indextree")
+ (synopsis
+ "Arena based tree structure by using indices instead of reference counted pointers")
+ (description
+ "Arena based tree structure by using indices instead of reference counted
+pointers")
+ (license license:expat)))
+
(define-public rust-indexmap-1
(package
(name "rust-indexmap")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 5/9] gnu: Added rust-serde-{wasm-bindgen-0.3,indextree-0.2}.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
407c6899b1cec31a44bb990e1400f1df7fcd75b0.1690467642.git.w@wmeyer.eu
* added rust-serde-wasm-bindgen-0.3 to crates-io.scm
* added rust-serde-indextree-0.2 to crates-io.scm
---
gnu/packages/crates-io.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 091bd3c399..815d48b6c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55438,6 +55438,50 @@ (define-public rust-serde-fmt-1
standard formatting APIs.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-serde-wasm-bindgen-0.3
+ (package
+ (name "rust-serde-wasm-bindgen")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "serde-wasm-bindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xzh1a3rhapirlca4rbvh6bycphxg5yjmdwjsqij3hl6wpl6b0v1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-fnv" ,rust-fnv-1)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2))))
+ (home-page "https://github.com/cloudflare/serde-wasm-bindgen")
+ (synopsis "Native Serde adapter for wasm-bindgen")
+ (description "Native Serde adapter for wasm-bindgen")
+ (license license:expat)))
+
+(define-public rust-serde-indextree-0.2
+ (package
+ (name "rust-serde-indextree")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "serde_indextree" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kzp3dk6smfy0509fd1sih9ai4a31kgpb1rshsxb0m2l01c7s3m7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-indextree" ,rust-indextree-4)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/PoiScript/serde_indextree")
+ (synopsis "Serializing indextree structure.")
+ (description "Serializing indextree structure.")
+ (license license:expat)))
+
(define-public rust-serde-ini-0.2
(package
(name "rust-serde-ini")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 6/9] gnu: Added rust-slugify-0.1 to crates-io.scm.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
14ecd28a4b6110293cf2bf380a4127c4e535ca35.1690467642.git.w@wmeyer.eu
* added rust-slugify-0.1 to crates-io.scm
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 815d48b6c8..3e3cdebe70 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58083,6 +58083,26 @@ (define-public rust-slotmap-1
(description "Slotmap data structure")
(license license:zlib)))
+(define-public rust-slugify-0.1
+ (package
+ (name "rust-slugify")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "slugify" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12xcybjhm7g2rql0n91lgb2j195za58qx3smswqvi2107lhczf6n"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-unidecode" ,rust-unidecode-0.3))))
+ (home-page "https://github.com/mattgathu/slugify")
+ (synopsis "Macro for flexible slug generation")
+ (description "Macro for flexible slug generation")
+ (license license:expat)))
+
(define-public rust-slug-0.1
(package
(name "rust-slug")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 7/9] gnu: Added rust-unidecode-0.3.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
768fa5435c6f3cbfdf1b28bde6d651fb15831ad4.1690467642.git.w@wmeyer.eu
* added rust-unidecode-0.3 to crates-io.scm
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3e3cdebe70..7a7d6b08d8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69065,6 +69065,26 @@ (define-public rust-ungrammar-1
"This package provides a DSL for describing concrete syntax trees.")
(license (list license:expat license:asl2.0))))
+(define-public rust-unidecode-0.3
+ (package
+ (name "rust-unidecode")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "unidecode" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1p0sm8j9223kw3iincv60s746s88k09xcaqf8nkx3w83isfv2as0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/chowdhurya/rust-unidecode/")
+ (synopsis "Provides pure ASCII transliterations of Unicode strings.")
+ (description
+ "This package provides pure ASCII transliterations of Unicode strings.")
+ (license license:bsd-3)))
+
(define-public rust-unic-char-property-0.9
(package
(name "rust-unic-char-property")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 9/9] gnu: Added rust-emacs-org-link-parser-0.1.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
b692e96baeade1d85fcffd3ba25e232974d3a06f.1690467642.git.w@wmeyer.eu
* added rust-emacs-org-link-parser-0.1 to crates-io.scm
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 58691253d0..b291c62ecb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41188,6 +41188,26 @@ (define-public rust-ordermap-0.3
under its new name.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-emacs-org-link-parser-0.1
+ (package
+ (name "rust-emacs-org-link-parser")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "emacs-org-link-parser" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0vvkl6wbgr1pc6abii2yra0saw0cca1wqm5sxflcmz1w47wrj7gx"))))
+ (build-system cargo-build-system)
+ (arguments
+ ;; The tests fail with: error[E0422]
+ `(#:tests? #f))
+ (home-page "https://github.com/lily-mosquitoes/emacs-org-link-parser")
+ (synopsis "Library for parsing Emacs Org-mode hyperlinks from a string")
+ (description "Library for parsing Emacs Org-mode hyperlinks from a string")
+ (license license:gpl3+)))
+
(define-public rust-os-info-3
(package
(name "rust-os-info")
--
2.40.1
W
W
Wilko Meyer wrote on 27 Jul 2023 16:31
[PATCH 8/9] gnu: Added rust-wee-alloc-0.4.
(address . 64898@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
d7c6c11b1e88b6e4ad714566c42b7d42eca0ebf6.1690467642.git.w@wmeyer.eu
* added rust-wee-alloc-0.4 to crates-io.scm
---
gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a7d6b08d8..58691253d0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -71936,6 +71936,30 @@ (define-public rust-webview-sys-0.6
GUIs as desktop applications.")
(license license:expat)))
+(define-public rust-wee-alloc-0.4
+ (package
+ (name "rust-wee-alloc")
+ (version "0.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "wee_alloc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13hb19nfqwjwcqlfj46sjz4j49wd7sj6hbjasimcn5xvnakbbcyv"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-0.1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-memory-units" ,rust-memory-units-0.4)
+ ("rust-spin" ,rust-spin-0.5)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/rustwasm/wee_alloc")
+ (synopsis "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+ (description "wee_alloc: The Wasm-Enabled, Elfin Allocator")
+ (license license:mpl2.0)))
+
(define-public rust-weezl-0.1
(package
(name "rust-weezl")
--
2.40.1
E
E
Efraim Flashner wrote on 5 Nov 2023 11:31
Re: [bug#64898] [PATCH 0/9] rust-emacs-org-link-parser & rust-orgize
(name . Wilko Meyer)(address . w@wmeyer.eu)(address . 64898-done@debbugs.gnu.org)
ZUdu5rf4NpgJL5Dp@3900XT
Thanks. I applied the patches to the rust-team branch.

On Thu, Jul 27, 2023 at 04:27:25PM +0200, Wilko Meyer wrote:
Toggle quote (32 lines)
> Hi Guix,
>
> I'd like to add two crates, rust-emacs-org-link-parser and rust-orgize,
> as well as their respective dependencies, to work with org-mode syntax
> in rust to crates-io.scm.
>
> Best Regards,
>
> Wilko Meyer
>
> Wilko Meyer (9):
> gnu: Added rust-indextree-4.
> gnu: Added rust-memory-units-0.4.
> gnu: Added rust-orgize-0.9.
> gnu: Bumped rust-rayon{,-core}-1 minor versions.
> gnu: Added rust-serde-{wasm-bindgen-0.3,indextree-0.2}.
> gnu: Added rust-slugify-0.1 to crates-io.scm.
> gnu: Added rust-unidecode-0.3.
> gnu: Added rust-wee-alloc-0.4.
> gnu: Added rust-emacs-org-link-parser-0.1.
>
> gnu/packages/crates-io.scm | 216 ++++++++++++++++++++++++++++++++++++-
> 1 file changed, 212 insertions(+), 4 deletions(-)
>
>
> base-commit: 76b7c50645cfba9554af9c80768765c5b714b893
> --
> 2.40.1
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmVHbuYACgkQQarn3Mo9
g1GjIRAAhcpJJTWcJ7DN8vdNQAT3r3jLLXL8NpUg5X9gaoHaULQNpZPUFHbeuecn
wx1ReZ+zZsu+LT3vnB5bk/AHVJdjBn9lvx7yKvOuPkSd6SsdgqOa2Hvf0pEfpSWr
NEM7Eie7ryqbUgvjxLVkeBWHUYQvvK8YY68gZAU1yPpHwIAwe04wzV4xw9brwisV
GFa2RRTRMotL7jXa1vbcBUkSRrysFqPiJOvqK//yKTM9ajiFVGDRgfbh/wvlfrsV
s/S0XZSJ9G+QHHZDFCDFExAcuNUS6m4tNoJ0XkXIFmVm259GXe/SvaUr+s4iBzjM
60NjitEcFLKyDehgybWLHe7r4t6Oawopo2nP2/LD+qKvQkwZaHGjZogqKcfCUbV5
NN8R1lfCZHePs2de2bKJLDuEg4Up4bPWDbkOfUAFb8KzLULt0XgVxSoJuHlohhrz
L+qFJPqBulwQGs09ORLFrIErZDIAchRU9Mf3rJkDsBatBMHse7TubrhBTp+QrqIh
DNLkNsy0tKoB5WmGoSh+DrI6HaP1PWOcHZX4jcmgdZMNzHmh6DKEgZrkzNBJjAqi
ujk0G+NFI5DeyNUoSHFCA+/Uf1Glzgy4Eq3DgUleJlNZukHzU653FMcvNDRwbzTh
Eg1Gy2qBbe1luoKoRVLOOavRIbNyNMR4W1E053s2YCT6FayePSY=
=nc4E
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64898@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64898
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch