(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
From 308b67848e93a25f627dd64e024e9a501979a157 Mon Sep 17 00:00:00 2001
Message-Id: <308b67848e93a25f627dd64e024e9a501979a157.1689368739.git.ekaitz@elenq.tech>
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Fri, 14 Jul 2023 22:52:59 +0200
Subject: [PATCH] gnu: Add hare
* gnu/packages/hare.scm (hare, harec): New variable.
* gnu/local.mk: Add hare.scm
---
gnu/local.mk | 2 +
gnu/packages/hare.scm | 104 ++++++++++++++++++++++++++++++++++++++++++
2 files changed, 106 insertions(+)
create mode 100644 gnu/packages/hare.scm
Toggle diff (134 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 06a376a99a..4d1645c595 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -59,6 +59,7 @@
# Copyright © 2023 Zheng Junjie <873216071@qq.com>
# Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
# Copyright © 2023 Andy Tai <atai@atai.org>
+# Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
#
# This file is part of GNU Guix.
#
@@ -314,6 +315,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/gv.scm \
%D%/packages/gxmessage.scm \
%D%/packages/hardware.scm \
+ %D%/packages/hare.scm \
%D%/packages/haskell.scm \
%D%/packages/haskell-apps.scm \
%D%/packages/haskell-check.scm \
diff --git a/gnu/packages/hare.scm b/gnu/packages/hare.scm
new file mode 100644
index 0000000000..0c65463e92
--- /dev/null
+++ b/gnu/packages/hare.scm
@@ -0,0 +1,104 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages hare)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages man))
+
+(define-public harec
+ (let ((revision "1")
+ (commit "f5da14c17f734f0bba5a741997b79d3e65a87712"))
+ (package
+ (name "harec")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/harec")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xdf9pdwy5dvxhgvw6hqkpnjl8z76xc413vsnbbqfvwmfing53yn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "CC" ,(cc-for-target))))
+ (add-after 'configure 'configure-better
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "./configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))))
+ (delete 'configure))))
+ (inputs (list qbe scdoc))
+ (synopsis "Bootstrapping compiler for Hare")
+ (description "Hare is a systems programming language designed to be
+simple, stable, and robust. Hare uses a static type system, manual memory
+management, and a minimal runtime. It is well-suited to writing operating
+systems, system tools, compilers, networking software, and other low-level,
+high performance tasks.")
+ (home-page "https://git.sr.ht/~sircmpwn/harec")
+ (license license:gpl3))))
+
+
+(define-public hare
+ (let ((revision "1")
+ (commit "112b75eb56d98c442094966fe59cbf3cd5feb909"))
+ (package
+ (name "hare")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/hare")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ilnz56757k4v0ggdc2v4xsjw0c944y8r289nfmqhw4hwzsrvb4j"))))
+ (inputs (list scdoc))
+ (propagated-inputs (list qbe harec))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags `("HARECACHE=./cache"
+ ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'configure-make
+ (lambda _
+ ;; NOTE: We are not really using this because overwriting it via
+ ;; `make-flags` is way easier with our tooling.
+ ;; Maybe we should?
+ (copy-file "config.example.mk" "config.mk")))
+ (delete 'configure))))
+ (synopsis "Hare build driver")
+ (description "Hare is a systems programming language designed to be
+simple, stable, and robust. Hare uses a static type system, manual memory
+management, and a minimal runtime. It is well-suited to writing operating
+systems, system tools, compilers, networking software, and other low-level,
+high performance tasks.")
+ (home-page "https://git.sr.ht/~sircmpwn/hare")
+ (license license:gpl3))))
base-commit: 917a299831361f253ea664f009176b4bbe06900a
--
2.39.2