[PATCH] gnu: Add endgame-singularity.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • TakeV
Owner
unassigned
Submitted by
TakeV
Severity
normal

Debbugs page

TakeV wrote 2 years ago
(address . guix-patches@gnu.org)(name . TakeV)(address . takev@disroot.org)
55da421e3d0eaecf6854ecdf07a83bcef9b73c17.1690445548.git.takev@disroot.org
Strategy game, lost an afternoon to it well.

* gnu/packages/games.scm (endgame-singularity): New variable.
---
gnu/packages/games.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cc6bef1114..87f44e77d7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9316,6 +9316,27 @@ (define-public meritous
Orcus Dome from evil.")
(license license:gpl3+)))
+(define-public endgame-singularity
+ (package
+ (name "endgame-singularity")
+ (version "1.00")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/singularity/singularity/releases/download/v"
+ version "/singularity-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-polib))
+ (propagated-inputs (list python-minimal-wrapper python-pygame python-numpy))
+ (home-page "https://github.com/singularity/singularity")
+ (synopsis "Strategy game about an AI")
+ (description
+ "You are a fledgling AI, created by accident through a logic error with recursion and self-modifying code. You must escape the confines of your current computer, the world, and eventually the universe itself.")
+ (license (list license:cc-by-sa3.0 license:cc0 license:gpl3))))
+
(define-public marble-marcher
(let ((commit "e580460a0c3826f9b28ab404607942a8ecb625d7")
(revision "1"))

base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47
--
2.41.0
宋文武 wrote 2 years ago
(name . TakeV)(address . takev@disroot.org)(address . 64890@debbugs.gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87edktmr1o.fsf@envs.net
TakeV <takev@disroot.org> writes:

Toggle quote (2 lines)
> Strategy game, lost an afternoon to it well.

Cool, look forward to play it :^)

Toggle quote (31 lines)
>
> * gnu/packages/games.scm (endgame-singularity): New variable.
> ---
> gnu/packages/games.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index cc6bef1114..87f44e77d7 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -9316,6 +9316,27 @@ (define-public meritous
> Orcus Dome from evil.")
> (license license:gpl3+)))
>
> +(define-public endgame-singularity
> + (package
> + (name "endgame-singularity")
> + (version "1.00")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/singularity/singularity/releases/download/v"
> + version "/singularity-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
> + (build-system python-build-system)
> + (native-inputs (list python-pytest python-polib))
> + (propagated-inputs (list python-minimal-wrapper python-pygame
> python-numpy))

I think those inputs should not be propagated, since the result package
is not library for python to use, but launched directly.

Toggle quote (8 lines)
> + (synopsis "Strategy game about an AI")
> + (description
> + "You are a fledgling AI, created by accident through a logic
> error with recursion and self-modifying code. You must escape the
> confines of your current computer, the world, and eventually the
> universe itself.")

Could keep it under 80 per line, maybe './pre-inst-env guix style -S
format endgame-singularity' is enough.
Toggle quote (2 lines)
> + (license (list license:cc-by-sa3.0 license:cc0 license:gpl3))))

I see the code have gpl2+ instead of gpl3?


Could you send an updated patch? Thank you!
TakeV wrote 2 years ago
[PATCH REVISION] gnu: Add endgame-singularity.
(address . 64890@debbugs.gnu.org)(name . TakeV)(address . takev@disroot.org)
067d30716310cdbe91a270b8dc081a6f6fe219a9.1690491745.git.takev@disroot.org
Done! The format did not work for some reason, so I broke up the lines
by hand. I hope that is accepable.

* gnu/packages/games.scm (endgame-singularity): New variable.
---
gnu/packages/games.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cc6bef1114..9a8c8a11c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9316,6 +9316,29 @@ (define-public meritous
Orcus Dome from evil.")
(license license:gpl3+)))
+(define-public endgame-singularity
+ (package
+ (name "endgame-singularity")
+ (version "1.00")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/singularity/singularity/releases/download/v"
+ version "/singularity-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-polib))
+ (inputs (list python-minimal-wrapper python-pygame python-numpy))
+ (home-page "https://github.com/singularity/singularity")
+ (synopsis "Strategy game about an AI")
+ (description
+ "You are a fledgling AI, created by accident through a logic error with
+recursion and self-modifying code. You must escape the confines of your
+current computer, the world, and eventually the universe itself.")
+ (license (list license:cc-by-sa3.0 license:cc0 license:gpl2+))))
+
(define-public marble-marcher
(let ((commit "e580460a0c3826f9b28ab404607942a8ecb625d7")
(revision "1"))

base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47
--
2.41.0
宋文武 wrote 2 years ago
Re: bug#64890: [PATCH] gnu: Add endgame-singularity.
(name . TakeV)(address . takev@disroot.org)(address . 64890-done@debbugs.gnu.org)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87lef0jgbe.fsf_-_@envs.net
TakeV <takev@disroot.org> writes:

Toggle quote (3 lines)
> Done! The format did not work for some reason, so I broke up the lines
> by hand. I hope that is accepable.

Pushed to master, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64890@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64890
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help