(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundationdevices.com)
* guix/transformations.scm (tuned-package): Use either bag-target if
available or bag-system to select the CPU architecture of the package
that is going to be tuned. This enables the tuning of cross-compiled
packages.
Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
guix/transformations.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (20 lines)
diff --git a/guix/transformations.scm b/guix/transformations.scm
index 92d9c89c0e..76d0208bf1 100644
--- a/guix/transformations.scm
+++ b/guix/transformations.scm
@@ -510,8 +510,9 @@ (define (lower* . args)
;; leading to an obscure build error, check whether the compiler is known
;; to support MICRO-ARCHITECTURE. If not, bail out.
(let* ((lowered (apply lower args))
- (architecture (match (string-tokenize (bag-system lowered)
- %not-hyphen)
+ (target (or (bag-target lowered)
+ (bag-system lowered)))
+ (architecture (match (string-tokenize target %not-hyphen)
((arch _ ...) arch)))
(compiler (any (match-lambda
((label (? package? p) . _)
base-commit: cf9904bcc8dd03e73675475bb4d8746dc434e415
--
2.34.1