[PATCH 0/1] gnu: picard: Update to 2.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • ???
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 26 Jul 2023 12:20
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1690366345.git.hako@ultrarare.space
Hello Guix!

This patch updates picard to 2.9. One test file (test_util_pipe.py) is deleted
since it fails in the build environment and I don't know how to fix it, the context
is given below.

Tests will succeed in the container spawned with "guix shell" with the following
commands:
Toggle snippet (10 lines)
cd /tmp/
tar xf /gnu/store/fdm4a4mk5fygdvkcwc612k6k24zkkl2s-picard-2.9.tar.gz
cd picard-release-2.9/
guix shell -CD picard

export SETUPTOOLS_SHIM="import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))"

python -c "$SETUPTOOLS_SHIM" build && python -c "$SETUPTOOLS_SHIM" test

But for "guix build", one test fails and check phase hangs with the following
output:
Toggle snippet (24 lines)
[...]
E: 09:46:44,831 util/pipe.read_from_pipe:244: pipe reader exception: ERROR: Pipe doesn't exist
E: 09:46:44,831 util/pipe._reader:346: Pipe file removed unexpectedly
E: 09:46:44,831 util/pipe.read_from_pipe:244: pipe reader exception: ERROR: Pipe doesn't exist
E: 09:46:44,831 util/pipe._reader:346: Pipe file removed unexpectedly
E: 09:46:44,832 util/pipe.read_from_pipe:244: pipe reader exception: ERROR: Pipe doesn't exist
E: 09:46:44,832 util/pipe._reader:346: Pipe file removed unexpectedly
.......s............................................................................................................................................................................................................................................s...........................................................................................................................s....................s.ss.ss.ss......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................s........s....s....s.............s.......s....s....s.........................................s.................s.......................................................................................................................................................................................................................................................................................................................................................................s..............ss......................s..............ss............s..............ss..................................s...s...........................s...s...........................s...s............................s...s............................s...s...........................s...s...........................s...s.................................s...s....................................s...s...........
======================================================================
FAIL: test_pipe_protocol (test.test_util_pipe.TestPipe)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/tmp/guix-build-picard-2.9.drv-0/picard-release-2.9/test/test_util_pipe.py", line 93, in test_pipe_protocol
self.assertEqual(res, message,
AssertionError: '' != 'it'
+ it : Data is sent and read correctly

----------------------------------------------------------------------
Ran 2329 tests in 44.455s

FAILED (failures=1, skipped=72)
At least one test failed.

Thanks

Hilton Chain (1):
gnu: picard: Update to 2.9.

gnu/packages/music.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)


base-commit: ca133a7c4d8bf07618b17a614b872fb8538da77b
--
2.41.0
H
H
Hilton Chain wrote on 26 Jul 2023 12:22
[PATCH 1/1] gnu: picard: Update to 2.9.
(address . 64870@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
091c3a4b784f64163c91f9d4b4115b16a8d4f1ba.1690366345.git.hako@ultrarare.space
* gnu/packages/music.scm (picard): Update to 2.9.
[arguments]<#:phases>: Add 'delete-failing-test.
---
gnu/packages/music.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8656716fd3..f3a4bf68ce 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3780,7 +3780,7 @@ (define-public pianobar
(define-public picard
(package
(name "picard")
- (version "2.8.5")
+ (version "2.9")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3788,7 +3788,7 @@ (define-public picard
"picard/picard-" version ".tar.gz"))
(sha256
(base32
- "1kjl7iqgvvrv7mygsb7491cz872gm334489nyj0v8b79bxnzghdi"))))
+ "0afiziaq49sq1dx5r3qis4ymhhkrqlrkfnb6f7gcksj0kwljvsw9"))))
(build-system python-build-system)
(arguments
(list
@@ -3805,7 +3805,13 @@ (define-public picard
(("pyfpcalc")
(string-append
"pyfpcalc', '"
- (assoc-ref inputs "chromaprint") "/bin/fpcalc"))))))))
+ (assoc-ref inputs "chromaprint") "/bin/fpcalc")))))
+ (add-before 'check 'delete-failing-test
+ (lambda _
+ ;; FIXME: This test fails in build environment.
+ ;; util/pipe.read_from_pipe:244: pipe reader exception:
+ ;; ERROR: Pipe doesn't exist
+ (delete-file "test/test_util_pipe.py"))))))
(native-inputs
(list gettext-minimal python-dateutil))
(inputs
--
2.41.0
?
Re: bug#64870: [PATCH 0/1] gnu: picard: Update to 2.9.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 64870-done@debbugs.gnu.org)
87v8dj8j2p.fsf_-_@envs.net
Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (3 lines)
> * gnu/packages/music.scm (picard): Update to 2.9.
> [arguments]<#:phases>: Add 'delete-failing-test.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64870@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64870
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch