(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
---
gnu/packages/inkscape.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)
Toggle diff (54 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a0..41fdbf22d0 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages fontutils)
@@ -286,7 +287,7 @@ (define-public inkscape
(package
(inherit inkscape/stable)
(name "inkscape")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(inherit (package-source inkscape/stable))
@@ -294,13 +295,18 @@ (define-public inkscape
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
+ (patches (list ))
(sha256
- (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
+ (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments inkscape/stable)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'fix-unaliased-2geom-reference
+ (lambda _
+ (substitute* (find-files "." "CMakeLists.txt")
+ (("2Geom::2geom") "2geom"))))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda* (#:key outputs #:allow-other-keys)
@@ -313,5 +319,7 @@ (define-public inkscape
`("GDK_PIXBUF_MODULE_FILE" =
(,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
(inputs (modify-inputs (package-inputs inkscape/stable)
- (append python-cssselect))) ;to render qrcode
+ (append gspell gtksourceview-4 lib2geom
+ python-cssselect ;to render qrcode
+ readline )))
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))
base-commit: 76e041f9eef85bb039c5251d3350c62ee2066883
--
2.41.0