[PATCH] gnu: inkscape: Update to 1.2.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 26 Jul 2023 08:09
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
87c693cd5cce2aaf8143d1c402edab25f98a05a7.1690351754.git.atai@atai.org
* gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
---
gnu/packages/inkscape.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a0..41fdbf22d0 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages fontutils)
@@ -286,7 +287,7 @@ (define-public inkscape
(package
(inherit inkscape/stable)
(name "inkscape")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(inherit (package-source inkscape/stable))
@@ -294,13 +295,18 @@ (define-public inkscape
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
+ (patches (list ))
(sha256
- (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
+ (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments inkscape/stable)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'fix-unaliased-2geom-reference
+ (lambda _
+ (substitute* (find-files "." "CMakeLists.txt")
+ (("2Geom::2geom") "2geom"))))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda* (#:key outputs #:allow-other-keys)
@@ -313,5 +319,7 @@ (define-public inkscape
`("GDK_PIXBUF_MODULE_FILE" =
(,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
(inputs (modify-inputs (package-inputs inkscape/stable)
- (append python-cssselect))) ;to render qrcode
+ (append gspell gtksourceview-4 lib2geom
+ python-cssselect ;to render qrcode
+ readline )))
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))

base-commit: 76e041f9eef85bb039c5251d3350c62ee2066883
--
2.41.0
A
A
Andy Tai wrote on 27 Jul 2023 07:21
[PATCH v2] gnu: inkscape: Update to 1.2.2
(address . 64867@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
26b7015b7e56c467f8f313d0179e1872f37a9810.1690435249.git.atai@atai.org
* gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
---
gnu/packages/inkscape.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a0..6b6ffb2738 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages fontutils)
@@ -286,7 +287,7 @@ (define-public inkscape
(package
(inherit inkscape/stable)
(name "inkscape")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(inherit (package-source inkscape/stable))
@@ -294,13 +295,18 @@ (define-public inkscape
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
+ (patches (list ))
(sha256
- (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
+ (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
(build-system cmake-build-system)
(arguments
(substitute-keyword-arguments (package-arguments inkscape/stable)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'fix-unaliased-2geom-reference
+ (lambda _
+ (substitute* (find-files "." "CMakeLists.txt")
+ (("2Geom::2geom") "2geom"))))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda* (#:key outputs #:allow-other-keys)
@@ -313,5 +319,7 @@ (define-public inkscape
`("GDK_PIXBUF_MODULE_FILE" =
(,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
(inputs (modify-inputs (package-inputs inkscape/stable)
- (append python-cssselect))) ;to render qrcode
+ (append gspell lib2geom
+ python-cssselect ;to render qrcode
+ readline)))
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))

base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47
--
2.41.0
M
M
Maxim Cournoyer wrote on 5 Sep 2023 17:06
Re: bug#64867: [PATCH] gnu: inkscape: Update to 1.2.2
(name . Andy Tai)(address . atai@atai.org)(address . 64867@debbugs.gnu.org)
87msy0irrs.fsf_-_@gmail.com
Hello,

Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2

You forgot to mention the actual (other) changes. readline was added;
is this intentional? The changelog helps ensuring it is.

Toggle quote (31 lines)
> ---
> gnu/packages/inkscape.scm | 14 +++++++++++---
> 1 file changed, 11 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
> index aa2c6419a0..6b6ffb2738 100644
> --- a/gnu/packages/inkscape.scm
> +++ b/gnu/packages/inkscape.scm
> @@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
> #:use-module (gnu packages python)
> #:use-module (gnu packages python-web)
> #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages readline)
> #:use-module (gnu packages xml)
> #:use-module (gnu packages ghostscript)
> #:use-module (gnu packages fontutils)
> @@ -286,7 +287,7 @@ (define-public inkscape
> (package
> (inherit inkscape/stable)
> (name "inkscape")
> - (version "1.2.1")
> + (version "1.2.2")
> (source
> (origin
> (inherit (package-source inkscape/stable))
> @@ -294,13 +295,18 @@ (define-public inkscape
> (uri (string-append "https://media.inkscape.org/dl/"
> "resources/file/"
> "inkscape-" version ".tar.xz"))
> + (patches (list ))

I'd use '() (and perhaps a comment).

Toggle quote (13 lines)
> (sha256
> - (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
> + (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
> (build-system cmake-build-system)
> (arguments
> (substitute-keyword-arguments (package-arguments inkscape/stable)
> ((#:phases phases)
> `(modify-phases ,phases
> + (add-after 'unpack 'fix-unaliased-2geom-reference
> + (lambda _
> + (substitute* (find-files "." "CMakeLists.txt")
> + (("2Geom::2geom") "2geom"))))

I'm a bit surprised by this change; did upstream update their way to
detect 2geom? Perhaps we could stop unbundling it ourselves.

Toggle quote (12 lines)
> (replace 'wrap-program
> ;; Ensure Python is available at runtime.
> (lambda* (#:key outputs #:allow-other-keys)
> @@ -313,5 +319,7 @@ (define-public inkscape
> `("GDK_PIXBUF_MODULE_FILE" =
> (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
> (inputs (modify-inputs (package-inputs inkscape/stable)
> - (append python-cssselect))) ;to render qrcode
> + (append gspell lib2geom
> + python-cssselect ;to render qrcode
> + readline)))

One package per line would be more readable here.
(append package1
package2
...)

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 5 Sep 2023 17:06
control message for bug #64867
(address . control@debbugs.gnu.org)
87ledkirrp.fsf@gmail.com
tags 64867 + moreinfo
quit
M
M
Maxim Cournoyer wrote on 24 Jan 15:58 +0100
Re: [bug#64867] [PATCH] gnu: inkscape: Update to 1.2.2
(name . Andy Tai)(address . atai@atai.org)(address . 64867@debbugs.gnu.org)
87le8eye0f.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (9 lines)
> Hello,
>
> Andy Tai <atai@atai.org> writes:
>
>> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
>
> You forgot to mention the actual (other) changes. readline was added;
> is this intentional? The changelog helps ensuring it is.

Gentle ping!

--
Thanks,
Maxim
A
A
Andy Tai wrote on 24 Jan 16:37 +0100
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 64867@debbugs.gnu.org)
CAJsg1E9j2iCG8yYtXT=KQA2tGAQUpmNan6s1htpR5eddKcyK6w@mail.gmail.com
OK I will update

On Wed, Jan 24, 2024 at 6:58?AM Maxim Cournoyer <maxim.cournoyer@gmail.com>
wrote:

Toggle quote (21 lines)
> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
> > Hello,
> >
> > Andy Tai <atai@atai.org> writes:
> >
> >> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
> >
> > You forgot to mention the actual (other) changes. readline was added;
> > is this intentional? The changelog helps ensuring it is.
>
> Gentle ping!
>
> --
> Thanks,
> Maxim
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 ??112?
????????????
????????????
Attachment: file
A
A
Andy Tai wrote on 13 Feb 08:57 +0100
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E9=udu0oq3C4_XvBXvZvcD+BJSD0f8V3Krp5wgSWAwf0g@mail.gmail.com
tags 64867 - moreinfo
thanks
M
M
Maxim Cournoyer wrote on 9 Mar 19:34 +0100
(name . Andy Tai)(address . atai@atai.org)(address . 64867-done@debbugs.gnu.org)
87jzmbdzl1.fsf@gmail.com
Hi,

Andy Tai <atai@atai.org> writes:

Toggle quote (18 lines)
> OK I will update
>
> On Wed, Jan 24, 2024 at 6:58?AM Maxim Cournoyer <maxim.cournoyer@gmail.com>
> wrote:
>
>> Hello,
>>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>> > Hello,
>> >
>> > Andy Tai <atai@atai.org> writes:
>> >
>> >> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
>> >
>> > You forgot to mention the actual (other) changes. readline was added;
>> > is this intentional? The changelog helps ensuring it is.

Inkscape has since been updated to 1.3.2 on core-updates.

Closing!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64867@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64867
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch