[PATCH 1/2] gnu: Add emacs-nominatim.

  • Done
  • quality assurance status badge
Details
3 participants
  • Clément Lassieur
  • Felix Lechner
  • pinoaffe
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 25 Jul 2023 17:33
5b6b04f992d2d24d84cf6de57913f72a042cea4a.1690319659.git.pinoaffe@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-nominatim): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d7e45fffc6..78469c1cf5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4748,6 +4748,30 @@ (define-public emacs-google-maps
directly inside Emacs. It requires a Google Map Static API key to function.")
(license license:gpl3+))))
+(define-public emacs-nominatim
+ ;; There has been no new release tag since july 2022
+ (let ((release "0.9.3")
+ (revision "0")
+ (commit "f814e16f8f4e2cfd633f52b29699a009ab704fbf"))
+ (package
+ (name "emacs-nominatim")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/nominatim")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19nw2iy8fxy6mfd4nwrdfa23a74a1b644400xx0900fwn6ihjhpl"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/emacs-weirdware/nominatim")
+ (synopsis "Forward and reverse geocode using Nominatim inside Emacs")
+ (description "This is an Emacs library which lets you forward and reverse
+geocode using Nominatim, a component of OpenStreetMap.")
+ (license license:gpl3+))))
+
(define-public emacs-graphviz-dot-mode
(package
(name "emacs-graphviz-dot-mode")

base-commit: 005912c595bf7a3329f8aa51a4ccb1d91b6ecd9e
--
2.41.0
P
P
pinoaffe wrote on 25 Jul 2023 17:33
[PATCH 2/2] gnu: Add emacs-org-street.
d3ae91de6c73712bed2f451cf2138cb4aed2136e.1690319659.git.pinoaffe@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-org-street): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 78469c1cf5..8e557feafa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4772,6 +4772,34 @@ (define-public emacs-nominatim
geocode using Nominatim, a component of OpenStreetMap.")
(license license:gpl3+))))
+(define-public emacs-org-street
+ ;; There has been no new release tag since july 2022
+ (let ((release "0.7.1")
+ (revision "0")
+ (commit "17913afe01504ee0cbcf83abaca18c5c618f9b33"))
+ (package
+ (name "emacs-org-street")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/org-street")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a5mnnvs4yxrw4s71z9ap65xi0fc1ki1qprif5jxn8apswjlmiw1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nominatim))
+ (home-page "https://codeberg.org/emacs-weirdware/org-street")
+ (synopsis "(Reverse) Geocoding for Emacs Org files")
+ (description "Org Street is an extension for Org Mode for turning the
+names of places into a LOCATION property containing their address. Given some
+freeform text approximately describing a location, it geocodes it with
+OpenStreetMap’s Nominatim API to determine a canonical location. If Nominatim
+returns multiple locations, a list is displayed to choose from.")
+ (license license:gpl3+))))
+
(define-public emacs-graphviz-dot-mode
(package
(name "emacs-graphviz-dot-mode")
--
2.41.0
P
P
pinoaffe wrote on 7 Sep 2023 11:15
[PATCH V2 1/2] gnu: Add emacs-nominatim.
(address . 64865@debbugs.gnu.org)
87sf7q4a52.fsf@gmail.com
Date: Thu, 07 Sep 2023 11:14:30 +0200
Date: Tue, 25 Jul 2023 17:33:27 +0200
User-agent: mu4e 1.10.5; emacs 28.2
base-commit: 5ef28595e9dff8b88ec3fcb4d887fbc380c9a8b8
* gnu/packages/emacs-xyz.scm (emacs-nominatim): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 55a2ffa53c..d168206dc7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4876,6 +4876,30 @@ (define-public emacs-google-maps
directly inside Emacs. It requires a Google Map Static API key to function.")
(license license:gpl3+))))
+(define-public emacs-nominatim
+ ;; There has been no new release tag since july 2022 (as of september 2023)
+ (let ((release "0.9.3")
+ (revision "0")
+ (commit "f814e16f8f4e2cfd633f52b29699a009ab704fbf"))
+ (package
+ (name "emacs-nominatim")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/nominatim")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19nw2iy8fxy6mfd4nwrdfa23a74a1b644400xx0900fwn6ihjhpl"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/emacs-weirdware/nominatim")
+ (synopsis "Forward and reverse geocode using Nominatim inside Emacs")
+ (description "This is an Emacs library which lets you forward and reverse
+geocode using Nominatim, a component of OpenStreetMap.")
+ (license license:gpl3+))))
+
(define-public emacs-graphviz-dot-mode
(package
(name "emacs-graphviz-dot-mode")

--
2.41.0
P
P
pinoaffe wrote on 7 Sep 2023 11:16
[PATCH 2/2] gnu: Add emacs-org-street.
(address . 64865@debbugs.gnu.org)
87o7ie4a3s.fsf@gmail.com
Date: Tue, 25 Jul 2023 17:33:40 +0200
User-agent: mu4e 1.10.5; emacs 28.2
* gnu/packages/emacs-xyz.scm (emacs-org-street): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d168206dc7..d416e13ecc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4900,6 +4900,34 @@ (define-public emacs-nominatim
geocode using Nominatim, a component of OpenStreetMap.")
(license license:gpl3+))))
+(define-public emacs-org-street
+ ;; There has been no new release tag since july 2022 (as of september 2023)
+ (let ((release "0.7.1")
+ (revision "0")
+ (commit "17913afe01504ee0cbcf83abaca18c5c618f9b33"))
+ (package
+ (name "emacs-org-street")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/org-street")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a5mnnvs4yxrw4s71z9ap65xi0fc1ki1qprif5jxn8apswjlmiw1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nominatim))
+ (home-page "https://codeberg.org/emacs-weirdware/org-street")
+ (synopsis "(Reverse) Geocoding for Emacs Org files")
+ (description "Org Street is an extension for Org Mode for turning the
+names of places into a LOCATION property containing their address. Given some
+freeform text approximately describing a location, it geocodes it with
+OpenStreetMap’s Nominatim API to determine a canonical location. If Nominatim
+returns multiple locations, a list is displayed to choose from.")
+ (license license:gpl3+))))
+
(define-public emacs-graphviz-dot-mode
(package
(name "emacs-graphviz-dot-mode")
--
2.41.0
C
C
Clément Lassieur wrote on 20 Oct 2023 18:25
(name . pinoaffe)(address . pinoaffe@gmail.com)(address . 64865-done@debbugs.gnu.org)
87o7gttg4y.fsf@lassieur.org
Both patches look good to me, I pushed them with a few cosmetic changes:

- `indent-region` on them

- I removed the comment, because a lot of packages are in this case (no
release for a long time) and I don't think there is a need to comment on
that.

- I removed the "release" local binding.

Thanks!

Sorry again for the delay.
Closed
F
F
Felix Lechner wrote on 29 Nov 2023 18:39
(no subject)
(address . control@debbugs.gnu.org)
87h6l4laqa.fsf@lease-up.com
unarchive 64865
reassign 64865 guix-patches
archive 64865
thanks
?